Вопросы с тегом 'unsupported-class-version'

UnsupportedClassVersionError вызывается, когда виртуальная машина Java пытается прочитать файл класса и определяет, что основные и младшие номера версий в файле не поддерживаются.
48

Как исправить java.lang.UnsupportedClassVersionError: Неподдерживаемая версия major.minor

Я пытаюсь использовать Notepad++ в качестве инструмента "все в одном" для редактирования, запуска, компиляции и т.д. У меня установлена JRE, и я установил переменную пути в каталог .../bin. Когда я запускаю свой "Hello world" в Notepad++, я получа...
30 апр. '12 в 11:28
26

Неподдерживаемая версия major.minor 52.0

Изображения: Командная строка с версиями Изображение ошибки Hello.java import java.applet.Applet; import java.awt.*; public class Hello extends Applet { // Java applet to draw "Hello World" public void paint (Graphics page) { ...
18 мар. '14 в 19:40
7

java.lang.UnsupportedClassVersionError Неподдерживаемая версия major.minor 51.0

Возможный дубликат: неподдерживаемая основная .minor версия 51.0 Я пытаюсь создать приложение, но оно дает некоторую ошибку. Моя версия JDK приведена ниже: java version "1.6.0_30" Java(TM) SE Runtime Environment (build 1.6.0_30-b12) Java HotS...
28 июн. '12 в 6:23
6

Установка Maven OSX Ошибка Неподдерживаемая версия major.minor 51.0

Я установил maven, выполнив следующие шаги: (учебник) JAVA_HOME=/Library/Java/Home export M2_HOME=/Users/steven/zimmermann/maven export M2=$M2_HOME/bin export PATH=$M2:$PATH echo $JAVA_HOME echo $M2_HOME echo $M2 echo $PATH nano .bash_profile т...
25 мар. '15 в 12:19
5

Исключение в потоке "main" java.lang.UnsupportedClassVersionError: a (Unsupported major.minor version 51.0)

Возможный дубликат: неподдерживаемая основная .minor версия 51.0 Я установил JDK7, простая программа hello word компилируется, но когда я запускаю это, я получил следующее исключение. Exception in thread "main" java.lang.UnsupportedClassVersi...
30 авг. '11 в 0:31
4

java.lang.UnsupportedClassVersionError

Когда я запускал java-программу, я получил эту ошибку. Не могли бы вы предложить, почему мы получаем эту ошибку: Exception in thread "main" java.lang.UnsupportedClassVersionError: GenerateInvoice (Unsupported major.minor version 49.0) a...
07 окт. '12 в 16:26
6

Java 6 Неподдерживаемая версия major.minor 51.0

Недавно я удалил Java 8, чтобы использовать Java 6, поскольку я хочу, чтобы мой код/​​творения мог использоваться больше людей, чем просто на Java 8. Когда я делаю mvn - version, он возвращает: Exception in thread "main" java.lang.UnsupportedClassV...
13 июл. '15 в 22:18
2

Неподдерживаемая версия major.minor 51.0, но все установлено на JDK 1.6

У меня есть приложение Maven Eclipse, которое я пытаюсь запустить через командную строку, используя следующую команду: java -cp target/classes;"target/dependency/*" com.example.Main К сожалению, это вызывает ошибку: UnsupportedClassVersionError :...
22 мар. '13 в 10:02
2

org.apache.catalina.LifecycleException: не удалось запустить компонент [StandardEngine [Catalina].StandardHost [localhost].StandardContext [/CollegeWebsite]]

org.apache.catalina.core.ContainerBase addChildInternal SEVERE: ContainerBase.addChild: start: org.apache.catalina.LifecycleException: Failed to start component [StandardEngine[Catalina].StandardHost[localhost].StandardContext[/CollegeWebsite]] ...
07 февр. '13 в 12:07
4

Разрешение конфликта версий между java и javac на Ubuntu

У меня проблема с моим скомпилированным Java-приложением на Ubuntu. Он выбрасывает UnsupportedClassVersionError. Я компилирую с более высокой версией JDK, чем тот, который настроен в моем PATH для запуска Java: $ javac -version javac 1.7.0_147 $ ja...
14 мая '12 в 14:15
3

Ошибка Java Stacktrace Неподдерживаемая версия major.minor 51.0

Возможный дубликат: неподдерживаемая основная .minor версия 51.0 Я сделал это script, и он дал мне эту ошибку: java.lang.UnsupportedClassVersionError: net/glitching/client : Unsupported major.minor version 51.0 at java.lang.ClassLoader.d...
15 июн. '12 в 22:59
4

java.lang.UnsupportedClassVersionError: неудачная основная версия при смещении = 6

Я разместил WAR file в папке webapps в tomcat. И когда я начинаю мой кот, как внизу C:\apache-tomcat-6.0.35\bin>startup.bat Using CATALINA_BASE: "C:\apache-tomcat-6.0.35" Using CATALINA_HOME: "C:\apache-tomcat-6.0.35" Using CATALINA_TMPDIR: ...
11 окт. '12 в 23:52
3

maven eclipse - Не поддерживается main.minor версия 52.0

Я использую apache maven 3.2.3 для компиляции моего проекта java. Когда я использую командную строку для запуска компиляции с помощью mvn clean compile тогда он отлично работает. Но когда я запускаю maven build из eclipse (LUNA), он всегда терп...
28 мар. '15 в 6:31
3

UnsupportedClassVersionError при запуске Ant из eclipse

Я пытаюсь запустить ant script из eclipse, но он не работает со следующим сообщением: BUILD FAILED project_path/build.xml:5: java.lang.UnsupportedClassVersionError: com/sun/tools/javac/Main : Unsupported major.minor version 51.0 Однако, когда я з...
29 янв. '13 в 10:54
1

Как установить JDK-версию для компиляции JSP-страниц?

Я сделал проект GAE в Eclipse Luna. Все работало нормально, пока я не добавил страницу JSP. Теперь, когда я развертываю новые версии, не имеет значения, вызван ли JSP или нет, я получаю следующее исключение: java.lang.UnsupportedClassVersionError: ...
26 апр. '15 в 17:02