Вопросы с тегом 'rvm'

RVM (Ruby Version Manager) - это инструмент командной строки, который позволяет пользователям устанавливать, управлять и работать с несколькими средами Ruby от интерпретаторов до наборов самоцветов в различных Unix-подобных системах (таких как Linux и Mac OS X).
10

Как удалить RVM (Ruby Version Manager) из моей системы?

Как удалить RVM (Ruby Version Manager) из моей системы?
24 авг. '10 в 16:26
1

Howto Uninstall RVM

Возможный дубликат: Как удалить rvm (менеджер версий ruby) из моей системы? Как я могу удалить (или переустановить) RVM на Ubuntu 9.10? Я испортил текущую установку.
16 окт. '10 в 18:42
16

Невозможно установить Ruby под Lion с проблемами RVM - GCC

Большинство вопросов, касающихся этой проблемы, связаны с отсутствием Xcode; У меня установлен Xcode 4.2. Ошибка установки: rvm install 1.9.3 Installing Ruby from source to: /Users/jamie/.rvm/rubies/ruby-1.9.3-p0, this may take a while depending on...
07 нояб. '11 в 4:46
23

Ошибка SSL При установке rubygems не удается извлечь данные из "https://rubygems.org/

Я пытаюсь сделать учебник Майкла Хартла. Когда я пытаюсь установить рельсы 3.2.14 в свой gemset, я получаю следующую проблему: $gem install rails -v 3.2.14 ОШИБКА: Не удалось найти действительный жемчуг "рельсы" (= 3.2.14), вот почему: Невозможно з...
03 окт. '13 в 2:56
26

rmagick gem install "Не удается найти Magick-config"

Я получаю ошибку, показанную ниже, при попытке установить драгоценный камень rmagick. Я на Snowleopard 10.6, используя RVM, Ruby 1.9.2-head и Rails 3.05. Ответы на подобные вопросы рекомендовали установить ImageMagick, который я успешно сделал. Други...
05 мар. '11 в 4:32
5

Используйте файл rvmrc или ruby-version для установки gemset проекта с RVM?

Я использую RVM, Ruby Version Manager, чтобы указать версию Ruby и набор драгоценных камней для каждого из моих проектов Rails. У меня есть файл .rvmrc для автоматического выбора версии Ruby и gemset всякий раз, когда я cd в каталог проекта. После...
29 мар. '13 в 18:09
20

Установка rvm не работает: "RVM не является функцией"

Я только что установил RVM, но не могу заставить его работать. У меня есть такая строка в конце моего файла .profile: [[ -s "$HOME/.rvm/scripts/rvm" ]] && . "$HOME/.rvm/scripts/rvm" Я попытался запустить source .profile и перезапустить т...
17 февр. '12 в 22:54
7

Установить autoreconf на OS X v10.7 (Lion)?

Я пытаюсь переустановить Ruby 1.9.3 с патчем, который позволит мне использовать ruby-debug. При следовании инструкциям и запуске rvm reinstall 1.9.3 --patch debug --force-autoconf Проходит и после применения патча выплевывает: rvm требует autor...
05 мар. '12 в 23:57
32

как решить проблему "рубиновая установка пропала без вести"?

Я использовал rvm для установки ruby ​​1.9.3. хотя он был успешно установлен, он жаловался на libyaml. и теперь каждый раз, когда я хочу установить драгоценный камень (скажем, рельсы), это предупреждение появляется: It seems your ruby installation i...
24 февр. '12 в 16:06
5

Как работают RVM и rbenv?

Мне интересно, как работают RVM и rbenv. Очевидно, они меняются между разными версиями Ruby и gemset, но как это достигается? Я предположил, что они просто обновляют символические ссылки, но вникая в код (и я должен признать, что мои знания Bash яв...
22 февр. '12 в 12:00
5

Есть ли эквивалент python Ruby 'rvm'?

Q: Есть ли у нас что-то функционально эквивалентное в Python для Ruby version manager 'rvm'? (RVM позволяет вам легко переключаться полностью между разными версиями интерпретатора ruby ​​ и разных наборов драгоценных камней (модулей). Все, что ...
11 мая '10 в 16:25
7

RVM: удаление всех драгоценных камней gemset

У меня есть глобальные драгоценные камни и различные гемзеты. Я хочу удалить все драгоценные камни gemset. Есть ли способ сделать это, помимо удаления gemset?
14 янв. '11 в 16:38
5

Как разрешить ошибку "gpg: command not found" во время установки RVM?

У меня есть новый mac pro (OS X 10.9.5), который я настраиваю с нуля. Я хочу установить RVM, и первое, что он говорит, это: Установить открытый ключ mpapis (может потребоваться gpg2 и или sudo) gpg --keyserver hkp://keys.gnupg.net --recv-keys D39...
20 нояб. '14 в 14:22
8

Установка в ошибках Homebrew

Попытка установить rvm и ruby ​​1.9.2 Я уже установил homebrew и git, но не смог получить полные обновления, потому что продолжал получать разрешения. Переустановил Snow Leopard и восстановил разрешения. Теперь это происходит... $brew установить...
26 янв. '11 в 11:45
8

Как обновить свой ruby ​​1.9.2-p0 до последнего уровня патча, используя rvm?

Моя текущая версия ruby ​​- ruby 1.9.2p0 (2010-08-18 revision 29036) [x86_64-darwin10.5.0], но я хочу обновить ее до последнего уровня исправления, используя rvm. Как я могу это сделать?
01 янв. '10 в 14:16