Вопросы с тегом 'pg'

'pg' - это имя расширения для Ruby, которое обеспечивает доступ к libpq, интерфейсу программистов приложений C к PostgreSQL RDBMS.
33
ответов

Не удается найти заголовок libpq-fe.h при попытке установить pg gem

Я использую предварительную версию Ruby on Rails 3.1. Мне нравится использовать PostgreSQL, но проблема заключается в установке pg gem. Это дает мне следующую ошибку: demonchand@system-001:~/exercise/personal/pro$ gem install pg Building native exte...
задан 18 мая '11 в 9:11
15
ответов

Как установить PostgreSQL pg gem на Ubuntu?

Я пытаюсь установить PostgreSQL pg gem для Ruby. Я выпустил следующую команду: gem install pg Я установил Ruby 1.9.2 с помощью RVM. Приведенная выше команда показывает мне следующую ошибку. Ошибка: Building native extensions. This could take ...
задан 25 июня '10 в 9:31
23
ответов

PG:: ConnectionBad - не удалось подключиться к серверу: соединение отклонено

Каждый раз, когда я запускаю сервер rails 4.0, я получаю этот вывод. Started GET "/" for 127.0.0.1 at 2013-11-06 23:56:36 -0500 PG::ConnectionBad - could not connect to server: Connection refused Is the server running on host "localhost" (::1) and ...
задан 07 нояб. '13 в 8:06
16
ответов

Rails 3 - не удается установить pg gem

Когда я пытаюсь запустить bundle (bundle install), я все время получаю Installing pg (0.13.2) with native extensions Gem::Installer::ExtensionBuildError: ERROR: Failed to build gem native extension. /Users/ryan/.rvm/rubies/ruby-1.9.2-p290/...
задан 12 марта '12 в 17:17
16
ответов

gem install pg --with-pg-config работает, пакет не работает

Когда я запускаю (как root) gem install pg -v '0.12.0' -- --with-pg-config=/usr/pgsql-9.1/bin/pg_config Я получаю следующий вывод: #-> gem instal pg -v '0.12.0' -- --with-pg-config=/usr/pgsql-9.1/bin/pg_config Building native extensions. This...
задан 11 февр. '12 в 0:20
8
ответов

Не удается установить pg gem в Mavericks с помощью Postgres.app

Я пытаюсь установить pg gem для использования с Postgres.app на моей локальной машине. Я бегу Маверикс. Postgres.app установлен и работает нормально, но я не могу заставить камень работать. Я сделал следующее: Используется команда env ARCHFLAGS = ...
задан 26 нояб. '13 в 20:55
10
ответов

ActiveRecord:: StatementInvalid: PG InFailedSqlTransaction

Я пытаюсь создать объект ActiveRecord. Но я получаю эту ошибку при ее создании. (0.1ms) ROLLBACK ActiveRecord::StatementInvalid: PG::InFailedSqlTransaction: ERROR: current transaction is aborted, commands ignored until end of transaction blo...
задан 15 янв. '14 в 16:05
11
ответов

ОШИБКА: Не удалось создать родное расширение gem на Mavericks

Я пытаюсь запустить bundle в проекте Rails на OSX 10.9. Это не удается при получении к pg драгоценности с этой ошибкой: Gem::Installer::ExtensionBuildError: ERROR: Failed to build gem native extension. /Users/kyledecot/.rvm/rubies/ruby-2.0.0-p...
задан 24 окт. '13 в 17:40
10
ответов

Адаптер Postgresql (pg): не удалось подключиться к серверу

Я получаю эту ошибку каждый раз, когда запускаю приложение Rails (он не может подключиться к моему локальному Postgresql) /Users/leonardo/.rvm/gems/ruby-1.9.3-p362/gems/activerecord-3.2.11/lib/ active_record/connection_adapters/postgresql_adapter....
задан 09 янв. '13 в 1:20
3
ответов

Установка камкордера PostgreSQL с "gem pq" завершается с ошибкой: ERROR: не удалось создать собственное расширение gem

Я изучаю Ruby on Rails и пытаюсь разработать приложение. В моем приложении я пытаюсь использовать стандартную базу данных SQLite в режиме разработки и PostgreSQL в режиме производства. Но при попытке установить pg gem я получаю следующую ошибку: ...
задан 18 сент. '13 в 7:52
10
ответов

rails install pg - Не удается найти заголовок libpq-fe.h

$ sudo bundle install Результат Fetching gem metadata from https://rubygems.org/........... Fetching gem metadata from https://rubygems.org/.. Using rake (0.9.2.2) Using i18n (0.6.1) Using multi_json (1.3.6) Using activesupport (3.2.8) Using b...
задан 26 окт. '12 в 14:27
13
ответов

gem install pg не работает на OSX Lion

Существуют вариации этого вопроса, подпрыгивающие вокруг SO, но ни у одного из них, похоже, нет ответа, который решает мою проблему. Я запускаю OSX Lion (10.7.3). Установлен последний XCode. Я установил Postgres, используя пакет Postgres.app из pos...
задан 27 апр. '12 в 7:42
4
ответов

Попытка настроить postgres для приложения ror, получить ошибку - fe_sendauth: пароль не указан

Получение: An error has occurred: Error connecting to the server: fe_sendauth: no password supplied Настройки database.yml совпадают с настройками приложения на других машинах. Как я могу настроить вещи так, чтобы я не нуждался в жестко закодиро...
задан 17 сент. '12 в 4:09
3
ответов

gem install pg не может связываться с libpq

После обновления до версии Ruby 1.9.3 (с версии 1.9.2 с использованием системы RVM) на Ubuntu 10.04.3 я удалил все мои драгоценные камни и попытался переустановить pg (ala bundle install pg). Затем он сделал ошибку и сообщил мне, что я должен посмо...
задан 11 янв. '12 в 9:10
2
ответов

PG:: Ошибка: ERROR: отношения "пользователи" не существуют

Извините за беспокойство, но у меня много вопросов об этой ошибке. сначала это мой файл user_controller rspec требуется "spec/spec_helper" describe UserController do it "create new user" do post "create" assigns[:users].should_not be_new_...
задан 17 июля '12 в 22:42