Вопросы с тегом 'composer-php'

Composer - это инструмент управления зависимостями в PHP. Он позволяет объявлять зависимости проекта и будет устанавливать их для вас. См. Http://getcomposer.org
6
ответов

Должен ли composer.lock быть приверженным контролю версий?

Я немного запутался в composer.lock, используемом в приложении с репозиторием. Я видел много людей, говорящих, что мы не должны .gitignore composer.lock из репозитория. Если я обновляю свои библиотеки в своей среде dev, у меня будет новый compos...
задан 15 окт. '12 в 16:36
3
ответов

Какая разница между require и require-dev?

Я новичок в composer, и мне хотелось бы узнать разницу между require и require-dev. На сайте композитора нет хорошего объяснения различий между этими двумя. Часть, которую я не получаю, это Lists packages required for developing this package, or ru...
задан 22 мая '13 в 0:13
4
ответов

Как обновить отдельную библиотеку с помощью Composer?

Мне нужно установить только 1 пакет для моего дистрибутива SF2 (DoctrineFixtures). Когда я запустил php composer.phar update Я получаю - Updating twig/twig (dev-master 39d94fa => v1.13.0) The package has modified files: M CHANGELOG ...
задан 24 мая '13 в 19:54
3
ответов

В чем разница между PSR-0 и PSR-4?

Я недавно читал об пространствах имен и о том, как они полезны. Я создаю проект в Laravel и пытаюсь перейти от автозагрузки классов к пространству имен. Я не могу понять, что представляет собой реальная разница между PSR-0 и PSR-4. Некоторые ресурс...
задан 21 июля '14 в 18:12
4
ответов

Композитор: как я могу установить другую зависимость без обновления старых?

У меня есть проект с несколькими зависимостями, и я хотел бы установить еще один, но я хотел бы оставить остальных такими, какие они есть. Поэтому я отредактировал composer.json, но если я запустил composer install, я получаю следующий вывод: Insta...
задан 05 марта '13 в 1:29
20
ответов

Running Composer возвращает: "Не удалось открыть входной файл: composer.phar"

Я новичок в symfony2 и читаю symblog. В третьей главе, пытаясь использовать данные, я попробовал команду: php composer.phar update но я получил ошибку: Could not open input file: composer.phar Итак, я немного погуглил и попробовал php compose...
задан 10 февр. '14 в 9:49
7
ответов

Как получить список всех установленных пакетов вместе с версией в композиторе?

Я работаю над проектом, использующим Symfony 2.1 на моей локальной машине. Я загрузил его на свой сервер, но когда я пытаюсь установить пакеты поставщиков с помощью Composer, я получаю много ошибок зависимостей. Предположительно, это связано с тем, ч...
задан 03 марта '13 в 15:06
12
ответов

Composer Warning: расширение openssl отсутствует. Как включить в WAMP

Попытка установить Composer инструмент управления зависимостями на Win7/64 + WampServer 2.2 с помощью Установщик установки, и я получаю следующее сообщение: Отсутствует расширение openssl, что уменьшит безопасность и стабильность Composer. Если во...
задан 28 дек. '12 в 1:21
7
ответов

Laravel 5 - семя ремесленника [ReflectionException] Класс SongsTableSeeder не существует

Когда я запускаю php artisan db: seed, я получаю следующую ошибку: [ReflectionException] Class SongsTableSeeder does not exist Что происходит? Мой класс DatabaseSeeder: <?php use Illuminate\Database\Seeder; use Illuminate\Database\Eloquen...
задан 01 окт. '14 в 17:05
11
ответов

Вы должны включить расширение openssl для загрузки файлов через https

Я хотел установить Zend Framework 2. Поэтому я загрузил приложение скелета. Как уже упоминалось в руководстве ZF2, мы должны выполнить команду php composer.phar install Внутри скелета. Но я получаю сообщение об ошибке Вы должны включить расшир...
задан 12 янв. '13 в 10:08
3
ответов

Как удалить неиспользуемые зависимости от композитора?

Я установил пакет с композитором, и он установил многие другие пакеты в качестве зависимостей. Теперь я удалил основной пакет с помощью composer remove packageauthor/packagename, но все старые зависимости не были удалены. Я ожидал, что композитор о...
задан 14 нояб. '14 в 16:12
18
ответов

Как включить расширение PHP openssl для установки Composer?

Я пытаюсь установить Laravel в настройке WAMP. Я получаю предупреждение о том, что не разрешаю openssl, который я уже сделал в WAMP. Вот скриншот сообщения.
задан 05 авг. '13 в 20:58
6
ответов

Проблемы с зависимостью lib-icu при установке Symfony 2.3.x через Composer

У меня не было проблем с установкой Symfony 2.2.x с использованием Composer, я всегда просто скопировал стабильную версию на http://symfony.com/download. composer create-project symfony/framework-standard-edition myproject/ 2.2.1 (У меня есть Comp...
задан 25 мая '13 в 22:21
5
ответов

Как правильно развертывать при использовании Composer develop/production switch?

Композитор имеет возможность загружать несколько зависимостей только при разработке, поэтому инструменты не будут установлены в процессе производства (на реальном сервере). Это (теоретически) очень удобно для скриптов, которые имеют смысл только в ра...
задан 12 февр. '14 в 10:35
10
ответов

Ошибка установки Composer - требуется ext_curl, когда он действительно включен

Я пытаюсь установить PHP PHP SDK с помощью Composer. Это то, что я получаю $ composer install Loading composer repositories with package information Installing dependencies (including require-dev) Your requirements could not be resolved to an instal...
задан 12 окт. '13 в 17:31