Ошибка построения: фатальная ошибка: pcre.h: нет такого файла или каталога

Я только что закончил установку Ubuntu 13.10.

Я хочу попробовать Phalcon, и когда я создаю источник (phalcon.so), у меня есть эта ошибка:

     from /home/fabrice/Downloads/cphalcon/build/32bits/phalcon.c:204:
/usr/include/php5/ext/pcre/php_pcre.h:29:18: fatal error: pcre.h: No such file or directory
 #include "pcre.h"
                  ^
compilation terminated.
make: *** [phalcon.lo] Erreur 1

Моя установка лампы:

sudo apt-get install -y apache2 php5 mysql-server libapache2-mod-php5 php5-mysql php5-curl php5-imagick php5-mcrypt php5-memcache php5-sqlite php5-xdebug php-apc php5-intl php-mongo php5-dev gcc

Может кто-нибудь мне помочь?

59
21 марта '14 в 13:00
источник поделиться
3 ответов

В последней версии Phalcon используются библиотеки PCRE.

Вы можете установить их так:

sudo apt-get install libpcre3-dev

а затем попробуйте снова установить Phalcon

Для CentOS вам нужно будет использовать

sudo yum install pcre-devel

Кредиты: @xgretsch

Для Mac вы можете использовать

brew install pcre

Кредиты @Брэндон Романо

172
21 марта '14 в 16:20
источник

Чтобы включить файл pcre.h, выполните поиск в архивах пакетов для файла pcre.h. Для этого я использую команду apt-file (

apt-get install apt-file

и

Обновление apt файла

если вы его не установили).

Затем выполните поиск пакета pcre:

apt-file search -x "/pcre.h $"

-x сообщает команде, что я хочу использовать регулярное выражение в качестве шаблона. apt-file предоставил мне три хита:

  • kannel-dev:/usr/include/kannel/gwlib/pcre.h
  • libajax6-dev:/usr/include/ajax/pcre.h
  • libpcre3-dev:/usr/include/pcre.h

Последний - тот, который я хочу:

apt-get install libpcre3-dev

Это решит проблему с проблемой компиляции файла pcre.h. Надеюсь, это поможет другим, кто может прийти, чтобы найти ответ на эту тему.

9
10 дек. '15 в 12:11
источник

Для mac osx maverick вы можете использовать

brew install pcre

если он дает вам ошибку, вы можете использовать

sudo ln -s /opt/local/include/pcre.h /usr/include/
sudo pecl install apc 
1
01 июня '16 в 15:37
источник

Посмотрите другие вопросы по меткам или Задайте вопрос