Apache VirtualHosts не работает независимо от того, что

Моя проблема

Я пробовал много методов, я исследовал массу вопросов на StackOverflow, и никто из них не работает! Некоторая информация:

  • Я запускаю Snow Leopard OS X (10.6.8)
  • Я использую XAMPP
  • Apache загружает каталог по умолчанию (резервное копирование). (См. Нижнюю часть вопроса, что я имею в виду)

Попытка решить

Вот те сайты, которые я пробовал:

Ошибка добавления VirtualHost: доступ запрещенной ошибки 403 (XAMPP) (SO)

Xampp vhosts не работают (SO)

Виртуальный хост Apache не работает правильно (SO)

Apache VirtualHost не работает (SO)

виртуальный хост не работает - Форум веб-сервера Apache на WebmasterWorld


Дополнительная информация

Мой файл VirtualHosts:

<VirtualHost wrks.tk:80>
    DocumentRoot "/Apps/XAMPP/htdocs/DNS"
    ServerName wrks.tk
    ErrorLog "/Logs/wrks.tk-error.log"
    CustomLog "/Logs/wrks.tk-access.log" common
    <Directory "/Apps/XAMPP/htdocs/DNS">
        AllowOverride All
        Order Allow,Deny
        Allow from all
        Require all granted
    </Directory>
</VirtualHost>

То, что оно фактически загружает (это каталог defualt в файле httpd.conf, в каталоге "backup"):

DocumentRoot "/Applications/XAMPP/xamppfiles/htdocs"
<Directory "/Applications/XAMPP/xamppfiles/htdocs">
    #
    # Possible values for the Options directive are "None", "All",
    # or any combination of:
    #   Indexes Includes FollowSymLinks SymLinksifOwnerMatch ExecCGI MultiViews
    #
    # Note that "MultiViews" must be named *explicitly* --- "Options All"
    # doesn't give it to you.
    #
    # The Options directive is both complicated and important.  Please see
    # http://httpd.apache.org/docs/trunk/mod/core.html#options
    # for more information.
    #
    #Options Indexes FollowSymLinks
    # XAMPP
    Options Indexes FollowSymLinks ExecCGI Includes

    #
    # AllowOverride controls what directives may be placed in .htaccess files.
    # It can be "All", "None", or any combination of the keywords:
    #   Options FileInfo AuthConfig Limit
    #
    #AllowOverride None
    # since XAMPP 1.4:
    AllowOverride All

    #
    # Controls who can get stuff from this server.
    #
    Require all granted
</Directory>
0
источник поделиться
1 ответ

Пара вещей, которые я проверял, это:

Убедитесь, что вы включили httpd-vhosts.conf

# Virtual hosts
Include /Applications/XAMPP/etc/extra/httpd-vhosts.conf

Настроить хосты:

перейдите на Macintosh HD/private/etc/hosts, в текстовый редактор и нажмите "Открыть". Затем добавьте эту строку:

127.0.0.1    wrks.tk

И, может быть, попробуйте:

<VirtualHost *:80>
    DocumentRoot "/Applications/XAMPP/xamppfiles/htdocs/DNS"
    ServerName wrks.tk
    ErrorLog "/logs/wrks.tk-error_log"
    CustomLog "/logs/wrks.tk-access_log" common
</VirtualHost>

Вы также можете снова настроить локальный хост.

<VirtualHost *:80>
    DocumentRoot "/Applications/XAMPP/xamppfiles/htdocs"
    ServerName localhost
</VirtualHost>

Извините, если некоторые из этих путей не точны, вам нужно будет проверить их на свою структуру папок xamp.

Простейшая реализация, которую я нашел, это: http://iwearshorts.com/blog/adding-a-virtual-host-vhost-in-xampp-on-a-mac/

0
источник

Посмотрите другие вопросы по меткам или Задайте вопрос