Запись уже добавлена

Все мои представления Razors имеют эту ошибку:

Метод инициализации запуска перед запуском. Начало по типу WebMatrix.WebData.PreApplicationStartCode создало исключение со следующим сообщением об ошибке:

Уже добавлена ​​запись "DefaultConnection".

Теперь, как вы можете видеть в моей конфигурации строки подключения, я не повторяю имя строки подключения:

<connectionStrings>
    <add name="DefaultConnection" connectionString="Data Source=.\foo;Initial Catalog=aspnet-foo-20130212133051;MultipleActiveResultSets=true;Integrated Security=SSPI" providerName="System.Data.SqlClient" />
    <add name="ServiDeskConnection" connectionString="Data Source=fooo;Initial Catalog=mdb;User Id=foo;Password=fooo;MultipleActiveResultSets=true" providerName="System.Data.SqlClient" />
    <add name="mdbEntities" connectionString="metadata=res://*/Models.ExternalData.ExternalContext.csdl|res://*/Models.ExternalData.ExternalContext.ssdl|res://*/Models.ExternalData.ExternalContext.msl;provider=System.Data.SqlClient;provider connection string=&quot;data source=foo;initial catalog=mdb;user id=foo;password=foo_prod01;multipleactiveresultsets=True;App=EntityFramework&quot;" providerName="System.Data.EntityClient" />
    <add name="SisInfoInventoryEntities" connectionString="metadata=res://*/Models.ExternalData.Inventory.csdl|res://*/Models.ExternalData.Inventory.ssdl|res://*/Models.ExternalData.Inventory.msl;provider=System.Data.SqlClient;provider connection string=&quot;data source=.\foo;initial catalog=foo;integrated security=True;multipleactiveresultsets=True;App=EntityFramework&quot;" providerName="System.Data.EntityClient" />
</connectionStrings>

Я уже пытался использовать <Clear/>, но это хуже, потому что он сказал, что у меня нет связи.

Я попытался выгрузить проект того же решения, но оно все еще не работает.

Обратите внимание, что когда я строю проект, он работает хорошо.

(Это ответ несколько раз, но ни одно из решений не сработало для меня.)

+15
01 апр. '14 в 4:48
источник поделиться
1 ответ

После <providers> и перед первым <add....> node добавьте <clear /> node. Это исправит это!

Или это может быть в файле web.config, который является родительским для этого. Просто добавьте код ниже, прежде чем добавлять его снова.

<remove name="DefaultConnection" />

В качестве альтернативы, очистите все строки подключения, используя

<clear />

Я бы предложил вам переименовать DefaultConnection на что-то еще, например MyAppServices.

+36
01 апр. '14 в 4:53
источник

Посмотрите другие вопросы по меткам или Задайте вопрос