Elasticsearch - Агрегация возвращает термины в ключе, но не в полном поле, как я могу вернуть полное поле?

В реализации elasticsearch у меня есть несколько простых агрегатов на основе нескольких полей, как показано ниже -

 "aggs" : {
    "author" : {
        "terms" : { "field" : "author" 
          , "size": 20,
          "order" : { "_term" : "asc" }
        }
    },
    "title" : {
        "terms" : { "field" : "title" 
          , "size": 20
        }
    },
    "contentType" : {
        "terms" : { "field" : "docType" 
          , "size": 20
        }
    }
}

Агрегаты работают нормально, и я получаю соответствующие результаты. но возвращаемое поле ключа заголовка (или любое другое поле - многословное слово) имеет агрегацию и результаты одиночного слова. Мне нужен полный заголовок в возвращаемом результате, а не просто слово, что не имеет большого смысла. как я могу это получить.

Текущие результаты (всего лишь фрагмент) -

"title": {
     "buckets": [
        {
           "key": "test",
           "doc_count": 1716
        },
        {
           "key": "pptx",
           "doc_count": 1247
        },
        {
           "key": "and",
           "doc_count": 661
        },
        {
           "key": "for",
           "doc_count": 489
        },
        {
           "key": "mobile",
           "doc_count": 487
        },
        {
           "key": "docx",
           "doc_count": 486
        },
        {
           "key": "pdf",
           "doc_count": 450
        },
        {
           "key": "2012",
           "doc_count": 397
        } ] }

ожидаемые результаты -

"title": {
         "buckets": [
            {
               "key": "test document for Qaru ",
               "doc_count": 1716
            },
            {
               "key": "this is a pptx",
               "doc_count": 1247
            },
            {
               "key": "its another document and so on",
               "doc_count": 661
            },
            {
               "key": "for",
               "doc_count": 489
            },
            {
               "key": "mobile",
               "doc_count": 487
            },
            {
               "key": "docx",
               "doc_count": 486
            },
            {
               "key": "pdf",
               "doc_count": 450
            },
            {
               "key": "2012",
               "doc_count": 397
            } }

Я просмотрел много документации, он объясняет разные способы агрегирования результатов, но я не мог найти, как получить полный текст, если поле в ключе в результате, пожалуйста, сообщите, как я могу это достичь?

24
08 июля '14 в 22:23
источник поделиться
3 ответов

Вам нужно иметь незакрашенные копии терминов в индексе, в вашем сопоставлении используйте несколько полей:

{
    "test": {
        "mappings": {
            "book": {
                "properties": {                
                    "author": {
                        "type": "string",
                        "fields": {
                            "untouched": {
                                "type": "string",
                                "index": "not_analyzed"
                            }
                        }
                    },
                    "title": {
                        "type": "string",
                        "fields": {
                            "untouched": {
                                "type": "string",
                                "index": "not_analyzed"
                            }
                        }
                    },
                    "docType": {
                        "type": "string",
                        "fields": {
                            "untouched": {
                                "type": "string",
                                "index": "not_analyzed"
                            }
                        }
                    }
                }
            }
        }
    }
}

В вашей задаче запроса на агрегирование неокенизированные поля:

"aggs" : {
    "author" : {
         "terms" : { 
            "field" : "author.untouched", 
            "size": 20,
            "order" : { "_term" : "asc" }
        }
     },
    "title" : {
        "terms" : { 
          "field" : "title.untouched", 
          "size": 20
        }
    },
    "contentType" : {
        "terms" : { 
           "field" : "docType.untouched", 
           "size": 20
        }
    }
}
28
08 июля '14 в 23:40
источник

Кажется, что multi_fields, указанные в вышеприведенном сообщении, устарели http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/_multi_fields.html#_multi_fields

0
07 авг. '14 в 7:18
источник

У меня возникла аналогичная проблема. Когда я выполнил команду:

   curl -XGET "localhost:9200/logstash*/_mapping?pretty"

в котором было полезно:

   "host" : {
     "type" : "string",
       "norms" : {
         "enabled" : false
       },
       "fields" : {
         "raw" : {
           "type" : "string",
           "index" : "not_analyzed",
           "ignore_above" : 256
         }
       }
     },...

Я понял, что добавление .raw должно изменить выход и получить желаемый результат.

так что-то вроде:

      "aggs": {
        "computes": {
          "terms": {
            "field": "host.raw",
            "size": 0
          }
        }         
      }

Сделал трюк для меня.

Новичок для поиска elastics, но я вижу, что много полей типа string имеет "необработанное" поле, которое можно использовать в запросе.

Было бы хорошо, если бы некоторые эксперты могли пролить свет на мои выводы. Правильно/частично правильно/Неверно?!

0
19 авг. '15 в 3:19
источник

Посмотрите другие вопросы по меткам или Задайте вопрос