Ng не распознается как внутренняя или внешняя команда

Запуск Windows 7 Professional 32bit.

Я попытался запустить npm install -g angular-cli как в обычном, так и в административном режиме. 2016-06-23_14h46_40

Я также попытался добавить его в переменные Enviorment в разделе PATH: (C:\Users\Administrator\AppData\Roaming\npm\node_modules\angular-cli\bin\ng), также не получив успеха.
2016-06-23_14h56_48

Что я делаю неправильно?

+143
23 июн. '16 в 12:24
источник поделиться
40 ответов
  • 1
  • 2

Я решил это несколько дней назад, после той же проблемы с другими глобальными модулями, добавив:

Таблицы окружения → Системные переменные → Путь:

C:\Users\Administrator\AppData\Roaming\npm\node_modules\angular -cli\bin; C:\Program Files\MongoDB\Server\3.2\bin

Обратите внимание, что после него не должно быть пробелов,

Это оказалось моей проблемой.

+12
01 июл. '16 в 9:47
источник

Для меня это работает с:

npm run ng <command>
+180
29 мар. '17 в 13:09
источник
другие ответы

Связанные вопросы


Похожие вопросы

Я решил эту проблему в соответствии с рисунком:

запустить в CMD

 npm install -g @angular/cli

а потом

(открыть в Windows 10) Панель управления\Все элементы панели управления\Система или в соответствии с рисунком

шаг 1:

enter image description here

шаг 2 :

enter image description here

шаг 3:

enter image description here

step4:

enter image description here

step5:

enter image description here

И в конце концов, компьютер должен быть перезагружен.

+135
06 сент. '17 в 2:53
источник

Добавление C:\Users\DELL\AppData\Roaming\npm в системную переменную Path работало для меня. Найдите подходящий путь к файлу "npm"

Кроме того, проверьте, добавили ли вы путь angular-cli\bin к переменной пути.

+105
11 нояб. '16 в 14:21
источник

Я использую WIN 10, просто подумайте об этом. Введите код ниже в cmd:

npm config get prefix

и скопировать и вставить путь, из которого вы получаете его сверху, в переменные среды компьютера → поле переменных пользователя → путь → изменить - C:\Program Files\nodejs\node_global, ваш путь может отличаться.

Нажмите "ОК" и повторно открыть ваше окно cmd, введите ng version, тогда он будет работать! Ура!

+55
19 июн. '17 в 4:19
источник

Просто откройте командную строку (запустите ее как администратор). Убедитесь, что node --v - 6.9.0 или выше, а npm --v - 3.0.0 r выше.

После этого выполните следующую команду:

npm install -g @angular/cli

После установки angular. вы можете увидеть запись angular cli в пути

C:\Users\Dell\AppData\Roaming\npm\node_modules\@angular

Затем попробуйте выполнить справку. Он будет работать.

+31
28 июн. '17 в 13:48
источник

С командой

npm install -g @angular/cli@latest

Работает нормально, теперь я могу запустить команду ng.

+15
05 апр. '18 в 10:07
источник

Вместо использования встроенной командной строки лучше начать использовать установленную версию командной строки NodeJS. Тогда он будет работать без проблем. enter image description here

+11
27 сент. '17 в 12:00
источник

Я следовал ниже шаги для решения этой проблемы в Windows 10:

  1. Сначала убедитесь, что вы установили Angular CLI. Вы можете использовать ниже, чтобы установить то же самое.

npm install -g @angular/cli @latest

  1. Убедитесь, что AppData видимы и перейдите к пути ниже.

C:\Users\rkota\AppData\Roaming\НПМ

Тот же путь можно найти, запустив ниже тоже:

npm config получает префикс

  1. Добавьте указанный выше путь, то есть "C:\Users\rkota\AppData\Roaming\npm", в переменную окружения PATH и убедитесь, что он был добавлен путем запуска пути в командной строке.
  2. Закройте командную строку и теперь попробуйте запустить ниже:

нг --version

Вы сможете увидеть версию CLI.

+10
24 июн. '19 в 10:12
источник

Если вы получите ошибку даже после выполнения вышеуказанного шага. затем попробуйте ниже.

Так как это node script. Я использую следующий вариант для создания на данный момент.

node C:\Users\Administrator\AppData\Роуминг\npm\ node_modules\angular -cli\bin\ng version

Возможно, нужны символические ссылки. Не изучено дальше.

О дальнейших исследованиях: Установить путь как:% PATH%; C:\Users\Administrator\AppData\Roaming\npm;

В Windows файл npm.cmd находится в указанном выше пути. Если указанная выше переменная среды установлена, вы можете выполнить ее как Версия для печати ng init

+9
19 авг. '16 в 7:56
источник

выполните следующие строки, чтобы решить проблему как для не найденной, так и для неопределенной версии ng

npm uninstall -g angular-cli

удаление npm --save-dev angular-cli

очистка кеша npm

npm install -g @angular/cli @latest

+9
24 февр. '18 в 16:21
источник
  • Откройте cmd и введите npm install -g @angular/cli
  • В переменных среды добавьте либо в пользовательскую переменную, либо системную переменную "Path" value = C:\Users\your-user\.npm-packages\node_modules\.bin
  • В cmd: c:\>cd your-new-project-path
  • ...\project-path\> ng new my-app

    или ng all-ng-commands

+7
06 авг. '17 в 7:25
источник

закрыть cmd и открыть его снова с помощью admin или перезагрузить систему ur.

+5
26 июн. '16 в 19:54
источник

Я столкнулся с той же проблемой, когда я пытался установить angular cli локально с помощью команды

npm install @angular/cli@latest

После этого у меня возникла та же проблема C:\Users\vi1kumar\Desktop\tus\ANGULAR\AngularForms> ng -v 'ng' не распознается как внутренняя или внешняя команда, работающая программа или командный файл

Чем я пытался установить глобально

npm install -g @angular/cli@latest

В этом случае это сработало, мне было интересно, что это не возможно установить CliG во всем мире?

После некоторого исследования я нашел эту статью очень полезной, надеюсь, она поможет кому-то, сталкивающемуся с подобной проблемой

Работа с несколькими версиями Angular CLI

+5
14 мар. '19 в 3:04
источник

npm install -g @angular/cli помог мне вместо npm install @angular/cli

+4
28 мая '18 в 14:45
источник

У меня была такая же проблема для Windows 7, 64 бит, запущенных с npm v3.10.8.

  • Я добавил путь, как было предложено: (C:\Users..... (ваше имя пользователя)\AppData\Roaming\npm\ node_modules\angular -cli\bin\ng) и удалено angular -cli.
  • После этого я очистил кэш npm с помощью npm cache clean, как было предложено здесь https://blogs.msdn.microsoft.com/matt-harrington/2012/02/23/how-to-fix-node-js-npm-permission-problems/. Это гарантирует отсутствие остатков.
  • Переустановлено angular -cli с помощью npm install -g angular-cli и voila.

    Надеюсь, что это может быть полезно!
+3
09 февр. '17 в 19:32
источник

Этот почти работал у меня, но мне пришлось использовать:% USERPROFILE%\AppData\Roaming\npm , В переменных среды.../Системные переменные/Путь

Затем, когда я сделал CMD: "ng -v", я получил правильный ответ для angular cli.

+3
24 мая '17 в 20:31
источник

У меня была такая же проблема, когда я попробовал синтаксис "ng new" и решил это, просто обновив существующую версию node от 5.x.x до 8.x.x. После успешного обновления node синтаксис отлично работал у меня. Обновите существующую версию node. Как ясно сказано в документации angular, что для этих команд требуется node version >= 6.9.x. Для справки, пожалуйста, проверьте https://angular.io/guide/quickstart. В нем четко указано: "Убедитесь, что вы используете как минимум node 6.9.x и npm 3.xx, запустив node -v и npm -v в окне терминала/консоли. Старые версии приводят к ошибкам, но более новые версии в порядке".

+3
22 июн. '17 в 11:17
источник

Я столкнулся с такой же проблемой на x86, windows 7;

  • uninstalled @ angular/cli
  • переустановлен @ angular/cli
  • проверенные и проверенные переменные среды (там нет проблем)...
  • Еще одна проблема:

Решение - это файл .npmrc в C:\Users {USERNAME}... измените префикс так, чтобы он читал "prefix = ${APPDATA}\npm"... Благодаря этот веб-сайт для помощи в его разрешении

+3
11 окт. '17 в 9:32
источник

В моем случае я сделал следующие шаги.

Все программы → Node JS- > Щелкните правой кнопкой мыши по Node.js Командная строка и выберите свойства и из целевой строки в конце копии ниже

/k "C:\Program Files\nodejs\nodevars.bat"

Я запустил код Visual Studio и открылся ниже файла

C:\Users\gochinta\AppData\Roaming\Code\User\settings.json и дал ниже

// Place your settings in this file to overwrite the default settings
{
  "terminal.integrated.shellArgs.windows": 
  ["/k", "C:\\Program Files\\nodejs\\nodevars.bat"]

}

Теперь я набрал ng -v в моем окне терминала Visual Studio Code, и он сработал.

+2
17 апр. '17 в 22:37
источник

Поскольку этот вопрос все еще задается снова и снова через год, я также отправлю свой ответ здесь.

Ключ (только для Windows) состоит в том, чтобы упорядочить записи в переменной пути вправо.

Как NPM wiki сообщает нам:

Поскольку установщик ставит C:\Program Files (x86)\nodejs перед C:\Users\\AppData\Roaming\npm на вашем PATH, он всегда будет использовать версию npm, установленную с node, а не версию npm вы установили с помощью npm -g install npm @.

Итак, ваша переменная path будет выглядеть примерно так:

…;C:\<path-to-node-installation>;%appdata%\npm;…

Теперь у вас есть две возможности:

  • Поменяйте две записи, чтобы они выглядели …;%appdata%\npm;C:\<path-to-node-installation>;… Это загрузит версию npm, установленную с номером npm (а не с помощью node), и с ней установлена ​​версия Agnular CLI.

  • Если вам (по какой-либо причине) нравится использовать версию npm в комплекте с node, добавьте прямой путь к вашей глобальной версии CLI Angualr. После этого ваша переменная path должна выглядеть так: …;C:\Users\<username>\AppData\Roaming\npm\node_modules\@angular\cli;C:\<path-to-node-installation>;%appdata%\npm;… или …;%appdata%\npm\node_modules\@angular\cli;C:\<path-to-node-installation>;%appdata%\npm;… для короткой формы.

Это сработало для меня через некоторое время.

+2
08 окт. '17 в 15:01
источник

Я сталкиваюсь с той же самой проблемой, и это решается. В конце я устанавливаю узел и интерфейс командной строки, используя другой профиль пользователя, и теперь я запускаю команду ng от имени другого пользователя. Так как узел и клиент, установленные с использованием другого узла входа пользователя, ничего не находят в C:\Users\&lt;user name&gt;\AppData\Roaming этому пути, и именно поэтому я получаю эту ошибку.

Я запускаю npm install -g @angular/cli и перезагружаю компьютер. Все работает нормально.

+2
26 дек. '17 в 15:15
источник

Я также пытался поиграть с cmd, установив переменную окружения path & etc, но простой ответ - использовать командную строку nodejs.

Таким образом, вам не нужно задавать путь переменной окружения или что-либо еще. Когда вы вызвали nodejs, он выдаст ему командную строку, используя эту команду "ng", без каких-либо настроек.

+2
22 окт. '18 в 11:22
источник

У меня была та же проблема, что и Visual Studio Code, не имея возможности запускать какие-либо команды ng в нем, встроенные в терминал.

Я добавил% AppData%\npm к пути в Windows 10 и не нуждался в перезагрузке, просто закрыл и снова открыл VS-код, но не видел его.

+1
15 авг. '17 в 19:46
источник

Установите x32 version nodejs вместо x64 версии (даже на 64-битной машине Windows).

+1
28 авг. '17 в 9:44
источник

Перейдите в каталог, в котором вы хотите создать приложение, и выполните команду:

PATH = "Путь, где установлен ваш узел";% PATH%

+1
30 мая '18 в 14:54
источник

Для меня что-то не так в переменной окружения PATH. Я удалил все пути, связанные с npm и добавил в начале PATH эту папку:

c:\Users\<your-user-name>\AppData\Roaming\npm\

Убедитесь, что у вас есть ; между дорожками.

+1
07 июн. '18 в 5:15
источник

Когда-нибудь в будущем. Применимо к машине с Windows 8.1. Запустите следующие команды

npm install -g @angular/cli

Выйдите из системы или перезагрузите компьютер.

Это должно добавить необходимый путь env, а не делать это вручную.

+1
09 окт. '18 в 4:51
источник

У меня была та же проблема, и я решил ее полностью, запустив VS Code от имени Администратора.

Я использовал вышеупомянутые решения (npm install -g @angular/cli @latest & npm install @angular/cli в моем проекте), пробовал ng serve как в терминале cmd, так и в VS Code, но не работал, в то время как npm запускал ng служить можно запустить в терминале VS Code, но я не был удовлетворен этим. После этого я установил путь в переменных окружения точно так же, как этот "C:\Users\TheUserName\AppData\Roaming\npm", и все еще не смог запустить ng serve.

Затем я запустил VS Code в качестве администратора, и он наконец заработал. Он даже распознал другую команду, gulp, которая не распознала до того времени, хотя у меня она также была правильно установлена. Не уверен, почему у него такое поведение, и я хотел бы объяснить.

+1
06 мар. '19 в 9:38
источник

Установить путь =% path%; C:\Users\\AppData\Roaming\npm

0
24 мая '17 в 9:43
источник
  • 1
  • 2

Посмотрите другие вопросы по меткам или Задайте вопрос