Насколько хороша поддержка jQuery для обратной совместимости?

У нас были проблемы с Mootools, которые не были очень совместимы в обратном направлении, особенно в области перетаскивания. Мне было интересно, есть ли у кого-то подобные проблемы с jQuery, которые не поддерживают обратную совместимость. Мы начинаем использовать его довольно сильно и думаем о переходе на новую версию, чтобы начать использовать несколько плагинов, которые этого требуют. Будут ли у нас какие-либо проблемы, если мы избавимся от старой версии?

30
задан Josh Mein 11 нояб. '08 в 19:41
источник поделиться
5 ответов

jQuery, похоже, хорошо совместим с обратной совместимостью. Я использую его уже более двух лет через несколько версий ядра и не имею проблем при обновлении, за исключением нескольких небольших с некоторыми плагинами. Я бы сказал, что ядро ​​кажется прекрасным, но если вы используете много плагинов, вы можете столкнуться с некоторыми проблемами (но их обычно легко исправить, или новое ядро ​​имеет встроенные функции, так что вы можете просто отказаться их).

26
ответ дан Lindsay 11 нояб. '08 в 20:00
источник поделиться

jQuery настолько серьезно относится к обратной совместимости, что для каждой версии они создают плагин "обратной совместимости": http://docs.jquery.com/Release:jQuery_1.2#jQuery_1.1_Compatibility_Plugin. Это позволило людям, которые не нуждаются в обратной совместимости, сохраняя при этом вес страницы.

16
ответ дан FriendOfFuture 11 нояб. '08 в 20:59
источник поделиться

Мой опыт в том, что при обновлении я иногда нахожу тот материал, который использовался для работы. Например, при обновлении с 1.7.2 до 1.8.3 я обнаружил, что некоторые функции перетаскивания перестали работать. Некоторые проблемы могут быть вызваны отказом устаревших функций jQuery, которые все еще используются несовместимыми версиями jQuery UI.

Вот цитата от другого пользователя:

Совместимость с обратной совместимостью может быть не сильной командой jQuery, но как и в большинстве случаев, его работа продолжается. Я не имею в виду унижают великую работу, которую они выполняют, но это указывает на то, что вы просто нужно всегда проверять свои скрипты с новыми версиями jQuery.

1
ответ дан Gruber 19 дек. '12 в 17:57
источник поделиться

По моему опыту, jQuery 1.x был очень обратно совместим до версии 1.9.

Линия jQuery 1.x имела существенные изменения по сравнению с jQuery 1.9.0. Мы настоятельно рекомендуем использовать плагин jQuery Migrate, если вы обновляете версии jQuery до 1.9, или вам нужно использовать плагины, которые еще не обновлены. Прочтите jQuery 1.9 Руководство по обновлению и jQuery 1.9 релиз блога для получения дополнительной информации.

И не обновляйте до 2.0, пока не убедитесь, что это не проблема для вас:

jQuery 2.x имеет тот же API, что и jQuery 1.x, но не поддерживает Internet Explorer 6, 7 или 8.

1
ответ дан Christian Davén 09 дек. '13 в 12:01
источник поделиться

jQuery выпустил обратно совместимые плагины с версии 1.0.

С годами веб-разработка сильно изменилась, и вместе с ней изменился jQuery. В течение всего этого времени команда пыталась пройти линию между поддержанием совместимости с кодом из прошлого и поддержкой лучших практик веб-разработки в настоящее время.

Проект имеет следующие обратные соглашения обратной совместимости:

Ссылки

0
ответ дан Paul Sweatte 08 окт. '16 в 0:18
источник поделиться

Другие вопросы по меткам