Установка Weblogic 12c (12.1.3) в Unix - искаженный символ в графическом интерфейсе через xMing

Я устанавливаю weblogic 12c (12.1.3) на RHEL (Red Hat Enterprise Linux Server 7.1) с использованием режима графического интерфейса. Я использую пересылку X11 с помощью XMing и подключение к серверу через SSH с использованием Putty. Когда я запускаю команду "java -jar Weblogic/fmw_12.1.3.0.0_wls.jar", она показывает некоторую начальную ошибку как "Проверка монитора: должна быть настроена на отображение 256-битного цвета". Ошибка. Я проигнорировал установку и пошел дальше. Но когда GUI открыл символы, они скремблировались и не читались, так как изображение прикреплялось к следующему графическому интерфейсу Weblogic. Не читаемый. Я попробовал установку с использованием JDK 1.7 и 1.8 и имел аналогичные результаты, которые, похоже, были проблемы с кодировкой символов, но не смог из. Я проверил переменную среды Unix $ LANG и правильно настроен на "en_US.UTF-8". Я проверил Putty, если есть какой-либо параметр, связанный с кодировкой. И нашел один в окне> Перевод> Удаленный набор символов, и значение установлено как UTF-8

Я проверил, скопировав текст внутри текстового поля рядом с эквивалентом Browse и вставив его в блокнот. Текст действителен в блокноте

-1
18 сент. '17 в 2:29
источник поделиться
3 ответа

Я нашел решение проблемы с помощью команды Unix. Я проверил другой установщик графического интерфейса, например, IBM Unica Campaign. У меня такая же проблема. Поэтому я был уверен, что это не имеет никакого отношения к установщику. Либо что-то с трубой SSH, либо что-то на сервере. Я рассказал подробности одного сервера, где он работал хорошо раньше, и попросил Unix-команду сравнить пакеты. Команда Unix Admin обнаружила, что проблема может быть вызвана шрифтом lyx-fonts, которого не было на сервере, где он работал нормально. Шрифт был удален командой администратора Unix. После этого установщик показывал правильную строку.

0
18 сент. '17 в 19:37
источник

У меня такая же проблема. Однако, если вы установите все необходимые компоненты (см. Руководство по требованиям Oracle Fusion Middleware 12c) для Linux, проблема исчезнет. В частности, вы должны установить redhat-lsb-4.1-27.0.1.el7 для x86_64 (Redhat или OEL 7). Это снова запустит lyx-шрифты, но также некоторые вещи, которые снова отображают ваш X-Windows.

0
13 мар. '18 в 13:35
источник

Также у меня была та же проблема. Я решил это. Я просто устанавливаю пакет "xorg-x11-fonts-Type1"

0
26 июл. '18 в 15:29
источник

Посмотрите другие вопросы по меткам или Задайте вопрос