Какую версию PostgreSQL я запускаю?

Я в корпоративной среде (под управлением Debian Linux) и не устанавливал ее сам. Я обращаюсь к базам данных с помощью Navicat или phpPgAdmin (если это помогает). У меня также нет доступа к оболочке на сервере, на котором запущена база данных.

768
задан 06 дек. '12 в 1:34
источник поделиться
15 ответов

Запустите этот запрос из PostgreSQL:

SELECT version();
1211
ответ дан 06 дек. '12 в 1:42
источник

Я считаю, что это то, что вы ищете,

Версия сервера:

pg_config --version

Клиентская версия:

psql --version
427
ответ дан 06 дек. '12 в 1:44
источник

Использование CLI:

Версия сервера:

$ postgres -V  # Or --version.  Use "locate bin/postgres" if not found.
postgres (PostgreSQL) 9.6.1
$ postgres -V | awk '{print $NF}'  # Last column is version.
9.6.1
$ postgres -V | egrep -o '[0-9]{1,}\.[0-9]{1,}'  # Major.Minor version
9.6

Если у вас установлено более одной установки PostgreSQL или возникает ошибка "postgres: command not found":

$ locate bin/postgres | xargs -i xargs -t '{}' -V  # xargs is intentionally twice.
/usr/pgsql-9.3/bin/postgres -V 
postgres (PostgreSQL) 9.3.5
/usr/pgsql-9.6/bin/postgres -V 
postgres (PostgreSQL) 9.6.1

Если locate не помогает, попробуйте find:

$ sudo find / -wholename '*/bin/postgres' 2>&- | xargs -i xargs -t '{}' -V  # xargs is intentionally twice.
/usr/pgsql-9.6/bin/postgres -V 
postgres (PostgreSQL) 9.6.1

Хотя postmaster также можно использовать вместо postgres, использование postgres является предпочтительным, поскольку postmaster является устаревшим псевдонимом postgres.

Клиентская версия:

Как релевантно, войти как postgres.

$ psql -V  # Or --version
psql (PostgreSQL) 9.6.1

Если имеется более одной установки PostgreSQL:

$ locate bin/psql | xargs -i xargs -t '{}' -V  # xargs is intentionally twice.
/usr/bin/psql -V 
psql (PostgreSQL) 9.3.5
/usr/pgsql-9.2/bin/psql -V 
psql (PostgreSQL) 9.2.9
/usr/pgsql-9.3/bin/psql -V 
psql (PostgreSQL) 9.3.5

Использование SQL:

Версия сервера:

=> SELECT version();
                                                   version                                                    
--------------------------------------------------------------------------------------------------------------
 PostgreSQL 9.2.9 on x86_64-unknown-linux-gnu, compiled by gcc (GCC) 4.4.7 20120313 (Red Hat 4.4.7-4), 64-bit

=> SHOW server_version;
 server_version 
----------------
 9.2.9

=> SHOW server_version_num;
 server_version_num 
--------------------
 90209

Если вам интересно, попробуйте => SHOW all;.

Клиентская версия:

Для чего стоит команда оболочки в psql, чтобы показать версию клиента исполняемого файла psql в пути. Обратите внимание, что запуск psql может потенциально отличаться от текущего в пути.

=> \! psql -V
psql (PostgreSQL) 9.2.9
189
ответ дан 29 апр. '14 в 23:32
источник

Выполнить команду

psql -V

Где

V должен находиться в капитале.

34
ответ дан 25 сент. '15 в 13:55
источник

в оболочке psql.exe выполните

\! psql -V
20
ответ дан 21 марта '18 в 8:57
источник

Принятый ответ хорош, но если вам нужно программно взаимодействовать с версией PostgreSQL, возможно, лучше сделать это:

SELECT current_setting('server_version_num'); -- Returns 90603 (9.6.3)
-- Or using SHOW command:
SHOW server_version_num; -- Returns 90603 too

Вернет версию сервера в виде целого числа. Вот как тестируется версия сервера в исходном коде PostgreSQL, например:

/*
 * This is a C code from pg_dump source.
 * It will do something if PostgreSQL remote version (server) is lower than 9.1.0
 */
if (fout->remoteVersion < 90100)
    /*
     * Do something...
     */  

Больше информации здесь и здесь.

19
ответ дан 09 мая '17 в 17:04
источник

Команда pg_config сообщит каталог, в котором установлены программы PostgreSQL (--bindir), расположение файлов с включением C (--includedir) и библиотек объектов (--libdir) и версия PostgreSQL (- -версия):

$ pg_config --version
PostgreSQL 9.3.6
8
ответ дан 23 апр. '15 в 9:22
источник

В моем случае

$psql
postgres=# \g
postgres=# SELECT version();
                                                       version
---------------------------------------------------------------------------------------------------------------------
 PostgreSQL 8.4.21 on x86_64-pc-linux-gnu, compiled by GCC gcc-4.6.real (Ubuntu/Linaro 4.6.3-1ubuntu5) 4.6.3, 64-bit
(1 row)

Надеюсь, что это поможет кому-то

8
ответ дан 18 июля '14 в 13:29
источник

Используя pgadmin4 это можно увидеть, дважды щелкнув Серверы> имя_сервера_ здесь> Свойства> Версия:

Версия 3.5:

pgadmin4 show postgres version. Servers > server_name > Properties > Version

Версия 4.1:

enter image description here

4
ответ дан 13 нояб. '18 в 22:42
источник

Если у вас есть доступ к серверу через оболочку (вопрос упоминает, что op не имеет, но в случае, если у вас есть) в системе debian/ubuntu

sudo apt-cache policy postgresql

который выведет установленную версию,

postgresql:
  Installed: 9.6+184ubuntu1.1
  Candidate: 9.6+184ubuntu1.1
  Version table:
 *** 9.6+184ubuntu1.1 500
        500 http://in.archive.ubuntu.com/ubuntu artful-updates/main amd64 Packages
        500 http://in.archive.ubuntu.com/ubuntu artful-updates/main i386 Packages
        500 http://security.ubuntu.com/ubuntu artful-security/main amd64 Packages
        500 http://security.ubuntu.com/ubuntu artful-security/main i386 Packages
        100 /var/lib/dpkg/status
     9.6+184ubuntu1 500
        500 http://in.archive.ubuntu.com/ubuntu artful/main amd64 Packages
        500 http://in.archive.ubuntu.com/ubuntu artful/main i386 Packages

где Installed: <version> - Installed: <version> установленного пакета postgres.

3
ответ дан 26 марта '18 в 0:20
источник

Если вы используете CLI и являетесь пользователем postgres, то вы можете сделать это:

psql -c "SELECT version();"

Возможный вывод:

                                                         version                                                         
-------------------------------------------------------------------------------------------------------------------------
 PostgreSQL 11.1 (Debian 11.1-3.pgdg80+1) on x86_64-pc-linux-gnu, compiled by gcc (Debian 4.9.2-10+deb8u2) 4.9.2, 64-bit
(1 row)
2
ответ дан 04 февр. '19 в 14:04
источник

Не знаю, насколько это надежно, но вы можете получить два токена версии полностью автоматически:

psql --version 2>&1 | tail -1 | awk '{print $3}' | sed 's/\./ /g' | awk '{print $1 "." $2}'

Таким образом, вы можете построить пути к двоичным файлам:

/usr/lib/postgresql/9.2/bin/postgres

Просто замените 9.2 этой командой.

2
ответ дан 20 окт. '14 в 14:21
источник

В моем случае, дополняя ответ @A-B-B, который отлично работает для меня, это следующее:

$ locate bin/postgres -- if not found, use "sudo updatedb" to update the index of locate command
/usr/lib/postgresql/9.0/bin/postgres -- local found
$ cd /usr/lib/postgresql/9.0/bin -- my local installation
$ sudo ./postgres -V
postgres (PostgreSQL) 9.0.23
2
ответ дан 28 марта '17 в 16:53
источник

Если Select version() возвращается с Memo, попробуйте использовать команду следующим образом:

Select version::char(100) 

или

Select version::varchar(100)
1
ответ дан 05 авг. '13 в 8:03
источник

Простой способ - проверить версию, набрав psql --version в терминале.

0
ответ дан 06 февр. '19 в 12:21
источник

Другие вопросы по метке или Задайте вопрос