Ошибка XAMPP 403 запрещена

Я просто установил XAMPP, и я создаю свои "проекты" в папке: /home/clement/Workspace/www/projects, но когда я хочу получить доступ к этой папке, у меня есть ошибка 403 Forbiden Access. Я думаю, что есть проблема в моем httpd-xampp.conf, но я не могу его найти.

Вот конфиг:

#<IfDefine PHP4>
#LoadModule php4_module        modules/libphp4.so
#</IfDefine>
#<IfDefine PHP7>
#LoadModule php7_module        modules/libphp7.so
#</IfDefine>

# We will enable it by default
#<IfDefine PHP>
   LoadModule php7_module        modules/libphp7.so
#</IfDefine>

LoadModule perl_module        modules/mod_perl.so

Alias /phpmyadmin "/opt/lampp/phpmyadmin"
Alias /phpsqliteadmin "/opt/lampp/phpsqliteadmin"

# since XAMPP 1.4.3
<Directory "/opt/lampp/phpmyadmin">
    AllowOverride AuthConfig Limit
    Require local
    ErrorDocument 403 /error/XAMPP_FORBIDDEN.html.var
</Directory>

<Directory "/opt/lampp/phpsqliteadmin">
    AllowOverride AuthConfig Limit
    Require local
    ErrorDocument 403 /error/XAMPP_FORBIDDEN.html.var
</Directory>

# since LAMPP 1.0RC1
AddType application/x-httpd-php .php .php3 .php4

XBitHack on

# since 0.9.8 we've mod_perl
<IfModule mod_perl.c>
        AddHandler perl-script .pl
    PerlHandler ModPerl::PerlRunPrefork
    PerlOptions +ParseHeaders
        PerlSendHeader On
</IfModule>

# demo for mod_perl responsehandler
#PerlModule Apache::CurrentTime
#<Location /time>
#      SetHandler modperl
#      PerlResponseHandler Apache::CurrentTime
#</Location>

# AcceptMutex sysvsem is default but on some systems we need this
# thanks to jeff ort for this hint
#AcceptMutex flock
#LockFile /opt/lampp/logs/accept.lock

# this makes mod_dbd happy - oswald, 02aug06
# mod_dbd doesn't work in Apache 2.2.3: getting always heaps of "glibc detected *** corrupted double-linked list" on shutdown - oswald, 10sep06
#DBDriver sqlite3

Я точно сделал ссылку на htdocs и мою папку.

0
источник поделиться
2 ответа

Попробуйте изменить порт с 80 на порт 8080. Или взгляните на эту статью, возможно, она поможет вам в вашей проблеме. Новая концепция безопасности xampp: доступ к запрещенной ошибке 403 - Windows 7 - phpMyAdmin

0
источник

Добавьте в свой файл conf следующее:

<Directory " /home/clement/Workspace/www/projects">
    Options Indexes FollowSymLinks Includes ExecCGI
    AllowOverride All
    Require all granted
</Directory>
-1
источник

Посмотрите другие вопросы по меткам или Задайте вопрос