Установка Android SDK не находит JDK

Я пытаюсь установить Android SDK на свою систему Windows 7 x64. jdk-6u23-windows-x64.exe установлен, но установка Android SDK не работает, потому что не находит установку JDK.

Это известная проблема? И есть ли решение?

SDK Error

+1116
07 дек. '10 в 22:12
источник поделиться
45 ответов
  • 1
  • 2

Нажмите Назад, когда вы получите уведомление, а затем Далее. На этот раз он найдет JDK.

+1241
25 февр. '11 в 10:12
источник

Действительный SETUP:

  • ОС: Windows 8.1
  • Файл JDK: jdk-8u11-windows-x64.exe
  • ADT файл: installer_r23.0.2-windows.exe

Установите x64 JDK и сначала попробуйте опцию back-next, а затем попробуйте установить JAVA_HOME, как указано в сообщении об ошибке, но если это не сработает для вас, попробуйте следующее:

Сделайте, как говорится, установите JAVA_HOME в переменные среды, но на пути используйте косые черты вместо обратных косых черт.

Серьезно.

Для меня это не удалось, когда JAVA_HOME был C:\Program Files\Java\jdk1.6.0_31, но работал нормально, когда он был C:/Program Files/Java/jdk1.6.0_31 - загнал меня в орехи!

Если этого недостаточно, добавьте также начало переменной окружения Path % JAVA_HOME%;

Обновленные значения в переменных среды системы:

  • JAVA_HOME=C:/Program Files/Java/jdk1.8.0_11
  • JRE_HOME=C:/Program Files/Java/jre8
  • Path=%JAVA_HOME%;C:...
+278
22 мар. '12 в 8:47
источник

Я нашел решение, и это красиво глупо. Я нашел Android SDK не может обнаружить JDK.

Нажмите кнопку Назад на экране ошибки SDK, в котором сообщается, что EXE не смог обнаружить JDK. Затем нажмите Далее.

Кто бы мог подумать, что это произойдет?

+95
18 мар. '11 в 4:06
источник

Кажется, что он не работает без 32-битного JDK. Просто установите его и будьте счастливы...

+87
08 дек. '10 в 17:05
источник

Вместо этого я загрузил архив .zip и запустил SDK Manager.exe, и он работал как шарм. В противном случае у вас была такая же проблема с .exe.

+33
14 дек. '10 в 17:04
источник

Предупреждение. Как отметил комментатор, не пробуйте это на Windows 7 7! Я протестировал его с 64-разрядной версией Windows XP.

Поскольку опубликованное решение НЕ работает для всех (включая меня, меня и меня), я хочу оставить заметку для тех, кто ищет другой способ (без взлома реестра и т.д.), чтобы решить эту проблему на 64-битной Windows система. Просто добавьте PATH (заглавные буквы!!) в свою среду Переменные и установите значение для вашего JDK-Path.

Я добавил JDK к существующему "Пути", который не работал, как это было не с JAVA_HOME или "Back" -Solution. Добавив его в "PATH", наконец, сделал трюк.

Я надеюсь, что это может быть полезно для кого-то.

+26
05 апр. '12 в 9:15
источник

Все, что вам нужно, это следующие две записи реестра. Кажется, что тот, кто разместил другой материал в реестре, просто скопировал все ключи из HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft в HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\JavaSoft, который, очевидно, не является идеальным решением, поскольку большинство ключей не нужны.

[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\JavaSoft\Java Development Kit]
"CurrentVersion"="1.6"

[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\JavaSoft\Java Development Kit\1.6]
"JavaHome"="C:\\Program Files\\Java\\jdk1.6.0_23"
+21
19 янв. '11 в 19:12
источник

Не все эти решения работали для меня. Я исправил его, временно изменив имя файла C:\Windows\System32\java.exe на java_.exe

+20
12 нояб. '12 в 21:30
источник

Ни одно из решений здесь не работало для 64-разрядной версии.

Помещение пути JDK до перехода c:\windows\system32\в переменную среды решает эту проблему. В противном случае 32-разрядный файл java.exe будет найден до 64-разрядной версии JDK.

+19
02 апр. '12 в 21:04
источник

После прочтения нескольких сообщений в блогах, кажется, это еще проще, нажав НАЗАД, когда установщик говорит, что не может найти JDK, а затем просто нажмите СЛЕДУЮЩИЙ снова и волшебным образом находит JDK. Никакой реестр не возится или не перезагружается и т.д.

+18
23 мар. '11 в 3:46
источник

Добавление переменной среды JAVA_HOME (в разделе Системные переменные) помогло мне. Нажатие кнопок "Назад" и "Далее" не работает.

Windows 7 Professional x64, JDK 1.7.0_04 (64 бит, у меня нет установленной версии x86)

Я думаю, что установщик пытается найти JDK в конкретной версии (1.6?), и если он не может его найти, проверяет JAVA_HOME, который не был установлен в моем случае. У меня есть другой компьютер (такая же система, но с JDK 1.6 x64), и он работал без переменной JAVA_HOME.

Вам не нужно устанавливать 32-разрядную версию JDK:)

+15
03 мая '12 в 19:27
источник

Я скопировал Java.exe из

C:\Windows\System32

to

C:\Windows\SysWOW64

и он работал.

Я использую 64-битную Windows 8.

+11
05 дек. '13 в 22:05
источник

Установка переменной среды JAVA_HOME в

C:\Program Files\Java\jdk1.7.0_07

вместо

C:\Program Files\Java\jdk1.7.0_07\bin

исправил это для меня.

+9
08 сент. '12 в 22:54
источник

Это исправление для реестра работало как прелесть моей установки Windows 7 x64: http://codearetoy.wordpress.com/2010/12/23/jdk-not-found-on-installing-android-sdk/

+8
03 янв. '11 в 4:03
источник

Нажмите Report error и OK. Next будет включен.

+8
06 февр. '12 в 22:39
источник

Парень выше, кто это сказал: "Я тоже испытал эту проблему, но ни один из ответов не помог. Что я сделал, Я удалил последнюю обратную косую черту из переменной JAVA_HOME и начал работать. включить папку bin в путь." Это был правильный ответ.

Для этого SDK для установки это то, что я сделал. Я запускаю последнюю ОС Microsoft Windows 8.

Пользовательские переменные:

Путь C:\Program Files\Java\jdk1.7.0_07\bin

Переменные среды

Создайте следующие два:

CLASSPATH %HOME_JAVA%\jre\lib

HOME_JAVA C:\Program Files\Java\jdk1.7.0_09

Этот уже существует, поэтому просто отредактируйте:

Путь В этом конце WindowsPowerShell\v1.0\ просто добавьте ";C:\Program Files\Java\jdk1.7.0_09"

Это то, что я сделал, и это сработало для меня. =)

+8
10 дек. '12 в 12:26
источник

Попробуйте загрузить и установить zipped-версию, а не программу .exe.

+7
14 дек. '10 в 2:34
источник

Кроме того, RUN AS ADMINISTRATOR! Работал для меня с исправлением обратной косой черты.

+6
16 сент. '12 в 19:12
источник

У меня была та же проблема, все решения были решены, но ничего не получилось. Проблема в том, что Windows 7 установлена ​​на 64 бит, и все программное обеспечение, которое вы устанавливаете, должно быть 32 бит. Android SDK сам по себе 32 бит, и он идентифицирует только 32-битный JDK. Поэтому установите следующее программное обеспечение.

  • JDK (32 бит)
  • Android SDK (при установке SDK обязательно установите его в каталог, отличный от "C:\Program Files (x86)", скорее всего, на другом диске или в каталоге, где Eclipse извлечен)
  • Eclipse (32 бит) и, наконец, ADT.

Я попробовал, и все работает нормально.

+5
06 мая '12 в 7:58
источник

У меня была такая же проблема, и я решил ее установить, установив x86-версию JDK (на Windows XP x64).

+5
20 дек. '10 в 12:12
источник

У меня тоже возникла эта проблема, но ни один из ответов не помог. Что я сделал, я удалил последнюю обратную косую черту из переменной JAVA_HOME и начал работать. Кроме того, не забудьте указать папку bin в пути.

+4
28 июн. '12 в 17:05
источник

РАБОЧИЙ РЕШЕНИЕ И НЕ НУЖЕН НЕОБХОДИМОГО ИЗМЕНЕНИЯ РЕГИСТРАЦИИ

Просто поставьте свой путь java bin перед вашей средой PATH.

PATH до

C:\Windows\system32;C:\Windows\%^^&^&^............(old path setting)

PATH после

C:\Program Files\Java\jdk1.6.0_18\bin;C:\Windows\system32;C:\Windows\%^^&^&^............(old path setting)

И теперь работает установщик Android SDK.

Кстати, я запускаю Win7 x64.

+4
10 февр. '13 в 7:31
источник

Android SDK - это 32-битное приложение, и для его работы требуется 32-разрядная JDK... 64-битный JDK не будет использовать его...

+4
07 авг. '12 в 18:26
источник

1 - Просто сделайте переменную переменную "JAVA_HOME".

2-Щелкните правой кнопкой мыши на Android SDK и на совместимой вкладке Выберите Windows 7 и администратор.

3-Запустите его снова.

+4
19 нояб. '14 в 20:54
источник

Для installer_r21.1-windows.exe в Windows 8 x 64 для меня работала настройка моей переменной окружения JAVA_HOME в C:\Program Files\Java\jdk1.7.0_10. Надеюсь, это поможет всем вам!:)

+3
27 мар. '13 в 22:43
источник

Да, установите 32-битную версию Java SE SDK (или любую из комбинаций). Это должно помочь решить вашу проблему.

+3
10 янв. '11 в 16:47
источник

Вам придется загрузить 32-разрядную версию SDK, поскольку 64-разрядная версия Win7 не поддерживается только Windows Server 2003 поддерживает 64-разрядную версию. Во время загрузки Java SDK выберите "Windows" в качестве вашей платформы, а не "Windowsx64".
Как только я установил этот Android-SDK как шарм. Надеюсь, это поможет.

+2
22 дек. '10 в 0:24
источник

Я запускаю 64-разрядную версию Windows 7, и я получал эту проблему при попытке установить Android Studio 1.0 с помощью исполняемого файла из:

http://developer.android.com/tools/studio/index.html

Я пробовал все перечисленные решения и несколько разных версий JDK 1.7 и 1.8 - без кубиков. Я пошел с установкой zipped версии приложения, и он работал как шарм:

http://tools.android.com/download/studio/canary/latest

Все еще озадачивается этой проблемой; тем более, что бета-версии Android Studio отлично работали.

+2
10 янв. '15 в 0:11
источник

Вышеуказанные методы не работали для меня в Windows 8 Pro.

Просто установите путь к

C:\Program Files\Java\jdk1.7.0_07\

Где C - ваш диск, на котором вы установили JDK.

Не забывайте обратную косую черту в конце.

+2
29 окт. '12 в 19:35
источник

Я попробовал несколько размещенных решений, а затем он перезагрузился, прежде чем он начал работать, возможно, потому, что я только что установил JDK. Вот все, что я делал, - не уверен, какие из них необходимы:

  • Установлен 64-разрядный JDK.
  • JAVA_HOME, определяемый с помощью косых черт (/) вместо обратных косых черт ().
  • Каталог JDK 'bin', указанный в начале PATH.
  • Перезагрузка системы.
+1
02 авг. '12 в 0:35
источник
  • 1
  • 2

Посмотрите другие вопросы по меткам или Задайте вопрос