Не удается запустить Eclipse - Java был запущен, но вернулся код выхода = 13

Я пытаюсь получить свой первый опыт разработки Android с помощью Eclipse. Я столкнулся с этой проблемой при попытке запустить Eclipse, установив версию 4.2 всего несколько минут назад.

Сначала попробовав запустить Eclipse без каких-либо параметров для указания виртуальной машины Java, я получил сообщение об ошибке, в котором говорилось, что не может найти виртуальную машину Java под названием javaw.exe внутри папки Eclipse, поэтому я нашел, где была установлена ​​и указана Java это местоположение в качестве параметра целевой цели. Теперь я получаю другую ошибку: "Java был запущен, но возвратил код выхода = 13".

Аналогичные вопросы, похоже, указывают на 32-битный/64-битный конфликт, но я на 99% уверен, что загрузил 64-разрядные версии Eclipse и Java (RE 7u5), которые я выбрал, потому что у меня есть 64-разрядная версия Windows 7.

  • Если кто-нибудь знает, как подтвердить, что мой Eclipse и Java являются 64-битными, это было бы оценено.
  • Если вы считаете, что моя проблема другая, пожалуйста, помогите!
  • Пожалуйста, говорите так ясно, как можете, так как я совершенно не знаком с Eclipse и Java.

Ярлык: "C:\Program Files\Eclipse-SDK-4.2-win32-x86_64\eclipse\eclipse.exe" -vm "C:\Program Files (x86)\Java\jre7\bin\javaw.exe"

Полный код ошибки...:

Java was started but returned exit code=13
C:\Program Files (x86)\Java\jre7\bin\javaw.exe
-Xms40m
-Xmx512m
-XX:MaxPermSize=256m
-jar C:\Program Files\Eclipse-SDK-4.2-win32-x86_64\eclipse\\plugins/org.eclipse.equinox.launcher_1.30v20120522-1813.jar
-os win32
-ws win32
-arch x86_64
-showsplash C:\Program Files\Eclipse-SDK-4.2-win32-x86_64\eclipse\\plugins\org.eclipse.platform_4.2.0.v201206081400\splash.bmp
-launcher C:\Program Files\Eclipse-SDK-4.2-win32-x86_64\eclipse\eclipse.exe
-name Eclipse
--launcher.library C:\Program Files\Eclipse-SDK-4.2-win32-x86_64\eclipse\\plugins/org.eclipse.equinox.launcher.win32.win32.x86_64_1.1.200.v201205221813\eclipse_1503.dll
-startup C:\Program Files\Eclipse-SDK-4.2-win32-x86_64\eclipse\\plugins/org.eclipse.equinox.launcher_1.30v20120522-1813.jar
--launcher.overrideVmargs
-exitdata 1e30_5c
-vm C:\Program Files (x86)\Java\jre7\bin\javaw.exe
-vmargs
-Xms40m
-Xmx512m
-XX:MaxPermSize=256m
-jar C:\Program Files\Eclipse-SDK-4.2-win32-x86_64\eclipse\\plugins/org.eclipse.equinox.launcher_1.30v20120522-1813.jar
+821
12 июл. '12 в 22:23
источник поделиться
30 ответов
  • 1
  • 2

Существуют рабочие комбинации OS, JDK и Eclipse. В моем случае я использовал 64-битный JDK с 32-разрядным Eclipse в 64-разрядной ОС. После понижения JDK до 32-бит, Eclipse начал работать.

Пожалуйста, используйте одну из следующих комбинаций.

  • 32-разрядная ОС, 32-разрядная JDK, 32-разрядная Eclipse (только 32-разрядная)
  • 64-разрядная ОС, 32-разрядная JDK, 32-разрядная Eclipse
  • 64-разрядная ОС, 64-разрядная JDK, 64-разрядная Eclipse (только для 64-разрядных)
+109
03 янв. '17 в 10:54
источник

Ваша версия Eclipse - это 64-разрядная версия, основанная на путях и именах файлов. Тем не менее, версия Java, которую он собирает, 32-битная, как указано, откуда она идет, в этой строке:

-vm C:\Program Files (x86)\Java\jre7\bin\javaw.exe

Program Files (x86) - это папка, в которой 64-разрядные Windows размещают 32-разрядные программы.

Program Files - это папка, в которой 64-разрядные Windows размещают 64-разрядные программы.

Это может произойти, если в системе установлено более одного JVM, как это часто бывает в Windows 64-bit (например, на странице загрузки JRE используется бит-версия браузера, чтобы определить, какая загрузка бит-версии вам предложит, и многие люди используют (d) 32-разрядные браузеры, хотя они работают с 64-разрядной Windows).

Лучший способ исправить это, если вы действительно имеете 64-битную JRE или JDK в своей системе, заключается в том, чтобы указать в eclipse.ini именно то, какую JVM вы хотите использовать. Инструкции подробно описаны на вики-странице Eclipse, но в основном вы должны указать параметр -vm в ini файле - обязательно прочтите страницу вики, поскольку формат очень специфичен.

Указание JVM-пути в eclipse.ini настоятельно рекомендуется, потому что это изолирует Eclipse от любых возможных изменений в вашей системе PATH которые могут быть PATH некоторыми установщиками программ (я говорю с вами, Oracle!).

Другой вариант - загрузить и использовать 32-разрядный Eclipse вместо 64-битного, но по-прежнему настоятельно рекомендуется указать путь к JVM в eclipse.ini.


Оставлено для исторической справки:

Чтобы проверить свою версию Java, запустите

  java -version 

в консоли (командной строке). В Windows 7 с 64-разрядной Java 6 я получаю:

  java version "1.6.0_27"
  Java(TM) SE Runtime Environment (build 1.6.0_27-b07)
  Java HotSpot(TM) 64-Bit Server VM (build 20.2-b06, mixed mode)

Обратите внимание на третью строку, которая показывает, что это 64-разрядная версия.

В 32-битной версии вы получите что-то вроде:

  Java HotSpot(TM) Client VM (build 20.1-b02, mixed mode, sharing) 
+672
12 июл. '12 в 22:29
источник

Связанные вопросы


Похожие вопросы

Я получил эту ошибку и обнаружил, что моя переменная PATH (в Windows), вероятно, была изменена. Сначала в моей PATH была эта запись:

C:\ProgramData\Oracle\Java\javapath

... и Eclipse ran "C:\ProgramData\Oracle\Java\javapath\javaw" - который дал ошибку. Я подозреваю, что это то, что пришло с установкой Java 8.

У меня установлено несколько версий Java (6,7 и 8), поэтому я удалил эту запись из PATH и снова попытался перезапустить Eclipse, который работал нормально.

Инструкции по изменению переменной PATH

+225
03 нояб. '14 в 7:20
источник

Если вы недавно установили Java 8 и удалили Java 7, установите JDK 8 и повторите попытку.

+178
30 окт. '14 в 14:06
источник

Для меня решение заключалось в том, чтобы войти (в Windows 8.1):

System > Advanced system setting > Environment Variables 

В разделе "Системные переменные" в переменной "Путь" было первое:

C:\ProgramData\Oracle\Java\javapath;

Я удалил это, и Eclipse снова работает!

+113
03 дек. '14 в 7:03
источник

У меня была такая же проблема, Java был запущен, но возвратил код завершения = 13.

Мое решение состояло в том, чтобы создать переменную окружения для свойств Windows имя переменной = значение переменной PATH = C:\Program Files\Java\jdk1.7.0_02\bin, а не C:\Program Files (x86)\Java\jre7\bin.

Затем я добавил строку в файл eclipse.ini → C:\Program Files\Java\jdk1.7.0_02\bin\javaw.exe.

Это сработало для меня.

+64
23 янв. '13 в 9:22
источник

enter image description here

Проблема была устранена, выполнив следующие шаги.

  • Eclipse находит исполняемые файлы JAVA из 'C:\ProgramData\Oracle\Java\javapath

  • Структура папок будет содержать ярлыки для следующих исполняемых файлов,
    я. java.exe
    II. javaw.exe
    III. javaws.exe

  • Для меня исполняемые пути указывали на расположение папки Program Files (x86) (для 32-разрядных приложений)

  • Я исправил его до Program Files (который размещает 64-разрядные приложения), и проблема была решена.

Пожалуйста, найдите скриншот для этого же.

+22
13 дек. '14 в 18:20
источник

Самое странное исправление. Посмотрите на свой путь Eclipse и убедитесь, что у вас нет странных символов (например, !, # и @). Это сработало для меня.

+22
04 дек. '12 в 10:50
источник

Добавление аргумента vm в файл .ini для меня

-vm
C:\Program Files\Java\jdk1.7.0_65\bin\javaw.exe
+16
16 мар. '15 в 13:52
источник

Я удалил обновление Java 25, и проблема была решена.

+10
21 окт. '14 в 6:22
источник

У меня было это сообщение, когда я забыл установить JDK.

+9
21 февр. '15 в 13:49
источник

Чистая переустановка Java JDK сделала трюк в моем случае. Сейчас я запускаю Eclipse 4.4 (Luna) как прелесть.

+8
13 февр. '15 в 12:46
источник

Найдите eclipse.ini:

Часто при C:\Users\xxx\eclipse\jee-neon\eclipse добавьте

-vm
 C:\Program Files (x86)\Java\jre7\bin\javaw.exe

после

--launcher.appendVmargs
+8
25 окт. '16 в 1:31
источник

Если вы установите 64-битную версию Eclipse на ПК с 32-разрядной JRE, это гарантировано.

Итак, решение довольно просто: вам нужно синхронизировать их, обновив один из них. Это произойдет при загрузке промежуточного программного обеспечения Oracle Fusion, а Eclipse ожидает 32-битную среду, в то время как ваша JRE - 64-разрядная, а ваш JAVA-дом указывает на 64-битный JDK.

+7
23 окт. '14 в 8:49
источник

Решение прост: поместите папку "eclipse" в "C: /Program Files". Если он не работает, поместите его в "C: /Program Files (x86)".

+7
25 окт. '12 в 1:44
источник

У меня была та же проблема. Я использовал Windows 8 с 64-разрядной ОС. Я только что изменил путь до Program Files (x86), а затем начал работать. Я поместил эту строку в файл eclipse.ini:

-vm
 C:\Program Files (x86)\Java\jre7\bin\javaw.exe
+7
07 авг. '14 в 5:37
источник

Убедитесь, что у вас нет специальных символов (%, $, # и т.д.) на пути Eclipse.

+7
27 мая '13 в 10:15
источник

Оказалось, что я установил только 32-разрядную среду выполнения Java.

C:\Program Files (x86)\Java\jre1.8.0_45\

Все Eclipse действительно хотели, чтобы я установил 64-битную среду выполнения Java. <= SOLVED

Java SE Runtime Environment 8u45  jdk-8u45-windows-x64.exe

http://www.oracle.com/technetwork/java/javase/downloads/jre8-downloads-2133155.html

Confirm your installation by checking you now have this folder

    C:\Program Files\Java\jre1.8.0_45\
+7
22 июн. '15 в 2:51
источник

Лучший ответ здесь слишком длинный. Я не могу комментировать, поэтому добавил свой ответ.

  • Перейдите сюда: http://www.oracle.com/technetwork/java/javase/downloads/index.html
  • Загрузите последнюю версию SDK (конечно, для x64, если ваш компьютер равен x64)
  • Установите его
  • Теперь вечеринка закончена, и пришло время работать с Eclipse;)
+6
10 февр. '15 в 9:13
источник

Я пробовал некоторые из решений, но не работал у меня.

Наконец, я нашел другой способ,...

Перейдите к переменным среды → Системные переменные

Задайте C:\Program Files\Java\jdk1.7.0_02\bin\javaw.exe путь к системным переменным.

Попробуйте. Это сработало для меня...

+6
24 нояб. '14 в 6:35
источник

У меня была эта проблема. Я установил Java 8 update 25 через Chrome, и попытка создания Eclipse дала указанную ошибку.

Удалено это обновление, а Eclipse снова работает.

+5
06 янв. '15 в 22:58
источник

Я только что решил ту же проблему при настройке своего ПК с Windows 8.1. Точно как @George Papatheodorou упомянутый выше (извините, я не могу добавить комментарий), Eclipse и JRE должны быть как 64-битными, так и 32-битными.

Однако, похоже, для среды Windows 8/8.1 вы по умолчанию получаете 32-разрядную JRE (и я не знаю, где изменить это значение по умолчанию для загрузки), как описано здесь: http://java.com/en/download/faq/win8_faq.xml

Я использовал 64-битное Eclipse, так что было расхождение. Затем я установил 32-разрядный Eclipse, и на этот раз все отлично работает.

Итак, прежде чем беспокоиться об изменении любых переменных среды, проверьте версию JRE и Eclipse.

Конечно, вы можете использовать 64-битную JRE с 64-разрядным Eclipse. Просто убедитесь, что они совпадают, потому что Windows 8.1 даст вам 32-бит по умолчанию.

+5
06 нояб. '14 в 16:28
источник

Я попробовал следующее решение:

Я создал ярлык javaw.exe из пути C:\Program Files\Java\jdk1.7.0_71\bin и вставил его в путь C:\ProgramData\Oracle\Java\javapath.

После этого я запустил Eclipse, и это сработало для меня.

+4
18 дек. '14 в 10:17
источник

Я также столкнулся с той же проблемой. Оказалось, что переменная окружения Path указывала на неправильную версию Java.

Проверьте переменную окружения и укажите ее на правильную Java. Например:

C:\Program Files (x86)\Java\jdk1.6.0_17\bin

Чтобы проверить переменную окружения, перейдите к:

Computer → properties → Advanced system settings → Advanced -> Environment variables
+3
13 мар. '15 в 7:35
источник

У меня была такая же проблема после того, как я обновил JDK с 1,7 до 1,8. Я использую Eclipse 4.4 (Luna). Ошибка исчезла после того, как я ухудшил JDK до 1.7.

+3
08 февр. '15 в 17:10
источник

Это может быть из-за слишком маленькой памяти. Вы можете изменить файл eclipse.ini для увеличения объема памяти. Что-то вроде этого может помочь вам: FAQ Как увеличить размер кучи, доступный для Eclipse?

+3
12 июл. '12 в 22:38
источник

Это может произойти, если у вас несколько версий Java на одной машине. Чтобы исправить это, я сделал следующее:

  • Проверено текущее значение JAVA_HOME. В Windows, echo %JAVA_HOME%
  • Доступ к маршруту javaw.exe
  • Заменили ярлыки, указывающие на исходное местоположение Java.
+3
21 окт. '14 в 16:01
источник
  • В переменных системной среды убедитесь, что "C:\ProgramData\Oracle\Java\javapath" удален.

  • В переменных системной среды убедитесь, что добавлен "C:\Program Files\Java\jdk1.8.0_131\bin".

введите описание изображения здесь

+3
04 нояб. '17 в 8:21
источник

У меня была аналогичная ошибка после установки Java 8 в моей 64-разрядной системе Windows 7 7.

Изменение переменных среды и т.д. не помогло. Поэтому я попытался удалить Java Update 8, но это тоже не помогло. Загрузка и установка 64-разрядной версии Java 8 SDK исправила мою проблему. Надеюсь, это поможет.

+3
23 янв. '15 в 13:59
источник

Проверьте, были ли вы настроены два пути JAVA в разделе "Переменная среда". Если вы уже установили две версии JDK, возможно, дважды проверьте, что вы поставили PATH для Java, как показано ниже.

PATH -->  C:\ProgramData\Oracle\Java\javapath

а также

JAVA_HOME ---> C:\Program Files\Java\jdk1.7.0_02\bin

Если оба они есть, может возникнуть такая ошибка.

Если все в порядке, проверьте файл ".ini", нижняя область в порядке или нет. Откройте файл ".ini" и проверьте

 -VM  path is  C:\Program Files\Java\jdk1.7.0_79\bin\

Если нет, пожалуйста, установите его так же, как и снова.

+2
26 сент. '16 в 8:55
источник
  • 1
  • 2

Посмотрите другие вопросы по меткам или Задайте вопрос