Номера строк Vim и комментарии зеленые, а не серые (tmux - solarized)

Стандартные цвета vim в терминале (tmux) по-прежнему не соответствуют цветам gvim. Я использую терминал пантеона в элементарной ОС freya. Это в сочетании с соляризованной темой: http://ethanschoonover.com/solarized

Когда я делаю "echo $ TERM" в tmux, вывод: screen-256color

Так что все в порядке. Из того, что я понимаю, значение $ TERM должно быть правильно определено в.bashrc. Tmux использует это, и vim использует значение TERM, которое он находит в tmux?

Цвета, которые я получаю, следующие: enter image description here

В пределах GVIM нумерация строк и комментарии серые? Как я могу это изменить. Другие цвета также не совпадают?

Мой gvim выглядит так: enter image description here

Я смотрю эту проблему часами...

Моя конфигурация выглядит следующим образом:

.bashr

# set a fancy prompt (non-color, unless we know we "want" color)
#case "$TERM" in
    #xterm-color) color_prompt=yes;;
#esac

# uncomment for a colored prompt, if the terminal has the capability; turned
# off by default to not distract the user: the focus in a terminal window
# should be on the output of commands, not on the prompt
#force_color_prompt=yes

if [ -n "$force_color_prompt" ]; then
    if [ -x /usr/bin/tput ] && tput setaf 1 >&/dev/null; then
    # We have color support; assume it compliant with Ecma-48
    # (ISO/IEC-6429). (Lack of such support is extremely rare, and such
    # a case would tend to support setf rather than setaf.)
    color_prompt=yes
    else
    color_prompt=
    fi
fi

if [ "$color_prompt" = yes ]; then
    PS1='${debian_chroot:+($debian_chroot)}\[\033[01;32m\]\u@\h\[\033[00m\]:\[\033[01;34m\]\w\[\033[00m\]\$ '
else
    PS1='${debian_chroot:+($debian_chroot)}\u@\h:\w\$ '
fi
unset color_prompt force_color_prompt

# If this is an xterm set the title to user@host:dir
case "$TERM" in
xterm*|rxvt*)
    PS1="\[\e]0;${debian_chroot:+($debian_chroot)}\u@\h: \w\a\]$PS1"
    ;;
*)
    ;;
esac

export EDITOR='vim'

### Start Tmux when opening terminal
if [[ ! $TERM =~ screen ]]; then
    exec tmux -2
fi

.tmux.conf

# reload source file to enable settings
#$ tmux source-file ~/.tmux.conf
bind r source-file ~/.tmux.conf \; display-message "Config reloaded..."

# Enable vi mode
set-window-option -g mode-keys vi

# Enable mouse control (clickable windows, panes, resizable panes)
set -g mouse-select-window on
set -g mouse-select-pane on
set -g mouse-resize-pane on

# switch panes using Alt-arrow without prefix
bind -n M-h select-pane -L
bind -n M-l select-pane -R
bind -n M-k select-pane -U
bind -n M-j select-pane -D

.vimrc

set background=dark
colorscheme solarized

При использовании пантеона $ TERM = xterm

Я также попробовал vim csapprox плагин. Это исправляет его большую часть, но комментарии остаются нечитаемыми.

enter image description here

1
01 дек. '15 в 23:26
источник поделиться
3 ответов

Я исправил его с помощью элементарных настроек. Это позволяет мне использовать солнечную тему в пантеоне. Все остальные настройки терминала не нужны.

enter image description here

Остальная часть моей конфигурации выглядит следующим образом:

.bashrc

export EDITOR='vim'

### Start Tmux when opening terminal
if [[ ! $TERM =~ screen ]]; then
    exec tmux
fi

.tmux.conf

# reload source file to enable settings
#$ tmux source-file ~/.tmux.conf
bind r source-file ~/.tmux.conf \; display-message "Config reloaded..."

# Enable vi mode
set-window-option -g mode-keys vi

# Enable mouse control (clickable windows, panes, resizable panes)
set -g mouse-select-window on
set -g mouse-select-pane on
set -g mouse-resize-pane on

# switch panes using Alt-arrow without prefix
bind -n M-h select-pane -L
bind -n M-l select-pane -R
bind -n M-k select-pane -U
bind -n M-j select-pane -D

.vimrc

let g:solarized_bold=1
let g:solarized_italic=1
let g:solarized_underline=1
set background=dark
colorscheme solarized

При выполнении echo $ TERM в tmux я получаю экран.

Как вы можете видеть, я удалил все цвета 256 упоминаний и материал работает. Комментарии все еще темные, но читаемые.

экран:

enter image description here

0
02 дек. '15 в 21:49
источник

С vim solarized github:

ВАЖНОЕ ЗАМЕЧАНИЕ ДЛЯ ПОЛЬЗОВАТЕЛЕЙ ТЕРМИНАЛА:

Если вы собираетесь использовать Solarized в режиме терминала (т.е. Не в графическом интерфейсе, таком как gvim или macvim), пожалуйста, подумайте о том, как настроить цветовую схему эмулятора терминала на использование Solarized palette. Я включил палитры для некоторого популярного эмулятора терминала, а также Xdefaults в официальной загрузке Solarized, доступной на Solarized homepage. Если вы используете Solarized без этих цветов, Solarized нужно будет сказать, чтобы снизить свою цветовую схему до набора, совместимого с ограниченной палитрой терминала 256 (тогда как при использовании значений цвета ansi терминала 16 вы можете установить правильные конкретные значения для Solarized палитра).

Если вы используете пользовательские цвета терминалов, solarized.vim должен работать из коробки для вас. Если вы используете эмулятор терминала, который поддерживает 256 цветов и не хотите использовать пользовательские цвета Solarized, вам нужно будет использовать дефрагментированную 256 цветов. Чтобы сделать это, просто добавьте следующую строку перед цветами в соляризованной линии:

let g: solarized_termcolors = 256 Опять же, я рекомендую просто менять цвета терминала на значения Solarized вручную или через одну из многочисленных схем терминалов, доступных для импорта.

2
02 дек. '15 в 12:28
источник

Используйте плагин csapprox vim. Он работает прозрачно и делает цвета одинаковыми или почти одинаковыми в gvim и в 256-цветном терминале.

.vimrc

let g:solarized_termcolors=256
let g:solarized_bold=1
let g:solarized_italic=1
let g:solarized_underline=1
let g:solarized_contrast="high"
set background=dark
colorscheme solarized

tmux.conf

set -g default-terminal "screen-256color"
1
02 дек. '15 в 4:32
источник

Посмотрите другие вопросы по меткам или Задайте вопрос