Как "выбрать Android SDK" в Android Studio?

После успешного импорта Eclipse-Android-Project в "Android Studio 1.4" я получаю сообщение об ошибке

"Пожалуйста, выберите Android SDK"

когда я нажимаю на кнопку, чтобы запустить приложение в симуляторе, но я не могу найти способ сделать это.

Это диалоговое окно открывается, когда я нажимаю "запустить":

This dialog opens up when I click on "run"

Это диалоговое окно "структура проекта":

Screenshot of the "project structure" dialog

Что мне теперь делать?

+961
18 дек. '15 в 10:16
источник поделиться
51 ответ
  • 1
  • 2

Я иду в build.gradle и нажмите кнопку синхронизации сейчас. Тогда это сработало.

Обновление:

FileSync Project with Gradle Files (Android Studio 3.1.1)

ToolsAndroidSync Project with Gradle Files (Android Studio 3.0.1)

Или Вы можете нажать на значок на панели инструментов.

Sync Project Icon

Этот ответ может не помочь в работе с более поздней версией, так как команда Android Studio работает над улучшением инструмента, способ синхронизации может быть другим в следующей версии Android Studio.

ОБЩИЙ СПОСОБ, который может помочь, это попытаться синхронизировать проект, а затем сделать недействительными кэши и перезапустить Android Studio.

Решение для Android Studio 3.1.2 [см. Ответ ниже]

Смотрите последнюю версию Android Studio

+1881
01 нояб. '16 в 8:57
источник

Связанные вопросы


Похожие вопросы

ИСПРАВЛЕНИЕ ДЛЯ 3.1.2 ИЛИ НОВЫЕ ВЕРСИИ

Я и некоторые из моих коллег столкнулись с такой же проблемой в AS 3.1.2, но простой Sync нам не помог. Для нас решение было несколько иным:

  1. File → Invalidate Caches → Invalidate
  2. Файл → Закрыть проект.
  3. Удалите проект из окна выбора проекта AS.
  4. Выйти из Android Studio
  5. Запустите AS и снова откройте проект

reopen project intructions

ДОПОЛНИТЕЛЬНЫЕ КОНСУЛЬТАЦИИ, ЕСЛИ ВЫ СДЕЛАЛИ ЭТОТ ВЫПУСК ПОСТОЯННО

Некоторые из вас постоянно сталкиваются с этой проблемой, и это "решение" исправляет ее только временно. В то время, когда мы начали получать эту ошибку, мы использовали gradle wrapper 4.6 и Android gradle plugin 3.1.0, но с тех пор мы вернулись к gradle 4.4, и мы используем его с последним плагином Android-плагинов, и мы не видели эту проблему с тех пор.

+451
24 апр. '18 в 11:20
источник

В Android Studio 3 и выше для Windows, Mac и Linux:

File -> Sync Project with Gradle Files

Решено!

Или вы можете сделать это с помощью сочетания клавиш:

Нажмите ⌘ + Shift + A (Mac) или Ctrl + Shift + A (Windows, Linux). Затем откройте Edit-Text и напишите "Sync Project with Gradle Files". Затем нажмите двойной щелчок на опции.

Ваша проблема решена! Это синхронизирует ваш файл Gradle с файлом вашего проекта, спасибо.

**Скриншот: **

enter image description here

+371
20 июн. '18 в 14:34
источник

Нажмите на эту иконку enter image description here для синхронизации gradle

или отредактировать любой из ваших gradle модуля, а затем синхронизировать

+208
15 сент. '17 в 8:13
источник

Нажмите "Ctrl+shift+A", а во всплывающем меню EditText напишите "Sync Project with Gradle Files". После этого дважды щелкните по появившейся опции. Затем он синхронизирует ваш файл Gradle SDK с файлом проекта.

+102
15 февр. '18 в 14:00
источник

Просто зайдите в файл build.gradle (на уровне приложения), дайте пустое место где-нибудь и нажмите на синхронизацию, после того, как град завершит синхронизацию, тогда Ошибка исчезнет

+74
07 мар. '18 в 7:00
источник

Теперь на Android Studio 3 и выше вы можете попробовать синхронизировать проект с градиентом:

File -> Sync Project with Gradle Files

enter image description here

+43
04 июн. '18 в 5:33
источник

Это самый простой способ исправить эту проблему:

  • Добавить строку комментария в файл градиента
  • Затем он попросит вас синхронизировать.
  • Нажмите " Синхронизировать сейчас ".

Это! Сделано.

+38
30 мар. '18 в 5:10
источник

Комментарий от @Nisarg помог: "установить последнюю версию в версии Compile Sdk"

Я изменил с API 8 на API 23, и сообщение об ошибке исчезло.

+35
19 дек. '15 в 12:11
источник

Нажмите " ⌘ + Shift + A " на Mac (или " Ctrl + Shift + A " в Windows), а во всплывающем EditText напишите " Sync Project with Gradle Files ". После этого дважды щелкните по появившейся опции. Затем он синхронизирует ваш SDK файла Gradle с файлом проекта.

+27
24 мая '18 в 20:18
источник

Нажмите первую кнопку обновления на вертикальной вкладке градации в Android Studio справа

enter image description here

+26
28 мар. '18 в 13:03
источник

Выполните следующие действия:

  • Перейти к настройкам Android Studio
  • Поиск "Android SDK" с помощью панели поиска
  • Убедитесь, что путь к вашей папке sdk для Android установлен правильно.
  • После этого также убедитесь, что путь автоматически обновляется после подсказки в файле проекта (local.properties). Если нет, сделайте это вручную.

Надеюсь, что это поможет.

+20
19 дек. '15 в 12:15
источник

У меня была эта проблема во всех версиях AS 3. 0+. Синхронизация с градиентом не решила проблему для меня. Решение от András Klöczl было единственным, что позволило бы мне получить некоторую кодировку. Проблема заключалась в том, что в любое время, когда мне приходилось выполнять градиентную синхронизацию, проблема вернулась. Поэтому я должен был пройти этот процесс в любое время, когда build.gradle внести изменения в свой build.gradle. То, что в конечном итоге работало на меня, было понизить мою версию 1.2.40 с 1.2.40 до 1.2.30

+18
01 мая '18 в 15:20
источник

Моя проблема заключалась в том, что если я сменил проект (например, открыли новое окно Android Studio с другим проектом), эта ошибка произошла.

Поэтому я прочитал каждый ответ в этом вопросе, и "ясные кеши и снова открыть проект" решение было не так полезно в моем случае.

Вместо этого я обнаружил, что если версия плагина Kotlin в Android Studio была ниже, чем в файле gradle, возникла проблема.

Моя настройка:

  • Android Studio 3.1.3
  • Плагин Kotlin (в Android Studio) 1.2. 30
  • Версия Kotlin в файле gradle 1.2. 51

Что поставило проблему?

Я обновил плагин Kotlin:

Файл → Настройки → Плагины → Установить плагин JetBrains...

Затем найдите Kotlin и нажмите "Обновить". После обновления просто перезапустите Android Studio и Sync Gradle.

+18
17 июл. '18 в 12:20
источник

введите описание изображения здесь

Перейдите в Файл → ProjectStructure (⌘;). Это откроет это окно, а затем выберите модуль app. Затем выберите версию SDK компиляции. Выберите последнюю и нажмите "Применить".

+16
23 янв. '18 в 19:23
источник

Это сработало для меня.

Файл → Настройки → Android SDK → Android SDK Location Edit → Android SDK

+16
02 янв. '18 в 23:21
источник

Просто измените версию инструмента сборки до 25.0.3.. и синхронизируйте сейчас Надеюсь, это поможет..

screenshot

+16
28 июн. '17 в 11:57
источник

Репозиторий поддержки Android, Android SDK Platform 28 и еще 3 компонента SDK не были установлены, введите описание изображения здесь

Поскольку я установил файл jdk, и он хорошо работает в eclipse, и я хочу начать работать в Android Studio, но всякий раз, когда я устанавливаю весь пакет менеджера SDK, он показывает, что установка не выполнена, пожалуйста, помогите мне.

+13
09 авг. '18 в 10:46
источник

Структура меню и параметры немного изменились по сравнению с Android 3.2.0. Я исправил эту ошибку, изменив Module SDK в следующем меню:

Файл> Структура проекта> Модули> Файл приложения> Вкладка "Зависимости"> Модуль SDK

Убедитесь, что нажали " Применить", чтобы сохранить изменения.

Modules Dependencies menu in Android Project Structure

+13
02 окт. '18 в 14:20
источник

Перейти к: Файл> Структура проекта> Модули → Приложение> Свойства

выберите: Скомпилируйте версию "SDK" = API26 Build Tools Версия = 27.0.0 Совместимость с исходным кодом = 1,8 Целевая совместимость = 1,8

+12
16 мая '18 в 8:30
источник

открыть файл build.gradle. просто добавьте пробел или нажмите клавишу ввода. затем синхронизировать проект. он работает...

+12
05 мар. '18 в 19:22
источник

Иногда андроид-студия просто действует глупо и нуждается в каком-то сбросе.

Перейдите в файл settings.gradle, который должен содержать include ':app'
измените его, чтобы include ':ap' и sync.
после синхронизации измените его, чтобы снова include ':app'.

Теперь он должен работать нормально.

+10
09 авг. '18 в 15:35
источник

Самое простое решение этой проблемы:

Сначала убедитесь, что ваш путь SDK является правильным. Затем, пожалуйста, закройте текущий проект и в меню запуска Android нажмите на проект импорта и выберите ваш проект из проводника. Это всегда решит мою проблему

+9
30 авг. '18 в 5:37
источник

В моем случае нет выбранной версии java sdk в структуре проекта -

Мне нужно было выбрать -

1. Совместимость источника (1.7)

Совместимость 2.Target(1.7)

как показано на рисунке.

введите описание изображения здесь

+9
05 февр. '18 в 6:28
источник

Перейдите в файл gradle.build и нажмите "Синхронизировать сейчас". Или щелкните значок в проекте "Синхронизация" с файлом Gradle

ИЛИ Перейдите в ИнструментыAndroidПроект синхронизации с файлом Gradle

+7
19 апр. '18 в 13:47
источник

Я просто перезапустил мою Android-студию, затем он перестроил проект, ошибка исчезла.

+7
21 июл. '16 в 15:32
источник

Если указан ваш путь к SDK для Android, и вы все еще сталкиваетесь с этой проблемой, это может быть вызвано тем, что ваша студия Android не синхронизирована хорошо, даже если вы нажали ссылку " Синхронизировать сейчас ".

Поэтому для повторной синхронизации перейдите в файл приложения gradle и внесите какие-либо изменения или просто выделите пробел и теперь выполните синхронизацию. Он будет работать отлично.

+6
07 мая '18 в 7:12
источник

Очистка и повторная синхронизация файлов Gradle работали для меня.

+6
16 авг. '17 в 20:10
источник

После открытия моего проекта в Android Studio я открыл версию приложения build.gradle, расположенную в папке Gradle Scripts проекта. Когда я навел указатель мыши на номер buildToolsVersion, всплыла всплывающая подсказка, указав, что необходимо обновить версию Android Build Tools (см. Снимок экрана). Я изменил значение buildToolsVersion на то, которое было определено ошибкой (27.0.2), и проблема была решена. Исходная ошибка (выберите Android SDK) исчезла, и проект был успешно скомпилирован. Хотя это решение было упомянуто ранее, точные шаги, казалось, отсутствовали, поэтому, надеюсь, это устраняет любые сомнения. Я полагаю, что основной причиной этой проблемы является то, что была выпущена новая версия инструментов сборки, но Android Studio не вызывала никаких уведомлений обо мне, что указывало бы на то, что я должен ее исправить вручную (поскольку Android Studio не видит способность обновлять этот файл build.gradle внутри), что оставляет проблему пользователю, чтобы найти проблему и исправить ее. введите описание изображения здесь

+6
25 дек. '17 в 18:28
источник

В моем случае я загрузил git-репозиторий для проекта Android. Для проекта требуется минимальная версия sdk 21 и целевая версия sdk 27. Когда я попытался запустить проект, он дал мне "Пожалуйста, выберите Android SDK error". Я проверил, что уже загрузил необходимые файлы sdk.

Для меня было решение "синхронизировать проект с файлами Gradle" enter image description here

+5
31 мая '18 в 5:00
источник
  • 1
  • 2

Посмотрите другие вопросы по меткам или Задайте вопрос